Can't Run rspec tests in vendor/plugins

Hi,

Run just doesn't seem to be an option for spec files in vendor/plugins.
I've added the directory as a test dir, but running still doesn't show
up as an option.

Spec Runner works great in spec/, but nowhere else.


Haven't used rubymine in a while, but I'm pretty sure this used to work.

cheers,
Charles

3 comments
Comment actions Permalink

Hi Charles,

Guest wrote:

Hi,


Run just doesn't seem to be an option for spec files in vendor/plugins.
I've added the directory as a test dir, but running still doesn't show
up as an option.

I've created simple spec file in /vendor/plugins and all works for me (RubyMine suggests to Run spec test in context menu)

0. What build of RubyMine do you use? Build #802 ?
1. Check that rspec, rspec-rails gems are attached to your RubyMine project (see Gems Manager settings).
2. Check that your spec file from plugins folder requires "spec" (directly on indirectly)
3. Check that "describe" method is in autocompletion popup
4. If 1-3 doesn't solve the problem please create simple spec file

# /vendor/plugins/my_example_spec.rb

require "spec"

describe "My behaviour" do

  it "should do something" do
    true.should == false
  end
end



5. If still doesn't work try to create run configuration for rspec file manually ( Run | Edit Configurations | + | RSpec)

0
Comment actions Permalink

Roman,

Thanks for the reply. The problem was that I did not have the gems
attached (shouldn't they have been picked up because they are in
vendor/gems?)



Roman.Chernyatchik wrote:

Hi Charles,

Guest wrote:
>
> Hi,
>
> Run just doesn't seem to be an option for spec files in vendor/plugins.
> I've added the directory as a test dir, but running still doesn't show
> up as an option.
>

I've created simple spec file in /vendor/plugins and all works for me (RubyMine suggests to Run spec test in context menu)

0. What build of RubyMine do you use? Build #802 ?
1. Check that rspec, rspec-rails gems are attached to your RubyMine project (see Gems Manager settings).
2. Check that your spec file from plugins folder requires "spec" (directly on indirectly)
3. Check that "describe" method is in autocompletion popup
4. If 1-3 doesn't solve the problem please create simple spec file

  1. /vendor/plugins/my_example_spec.rb

>
> require "spec"
>
> describe "My behaviour" do
>
> it "should do something" do
> true.should == false
> end
> end
>
>
>

5. If still doesn't work try to create run configuration for rspec file manually ( Run | Edit Configurations | + | RSpec)

---
Original message URL: http://www.jetbrains.net/devnet/message/5234818#5234818

0
Comment actions Permalink

Charles,

Thank you for issue. You are right RM didn't attach frozen gems due to some bugs. I've created issue http://www.jetbrains.net/jira/browse/RUBY-3596

0

Please sign in to leave a comment.