Whitespace at end of lines in editor

Hello-

I noticed that RubyMine assumes that there is a lot of whitespace at the end of each line in the editor, so if I click 20 characters from the end of the line, that is where the cursor is placed. This seems to me to not be the typical use case. Often, I just want to go to the end of the line. With the extended whitespace, I need to click in the exact place, instead of just clicking anywhere at the end of the line. This is actually less annoying than navigating with the keyboard. When I get to the end of the line and press the right arrow key, it adds a space, rather than wrapping around to the next line, which is what I would expect it to do. This means that to get the the start of the next line of code, I need to hit the down arrow, then the home key. Since I do this all day, it gets tiresome. Is the way RubyMine handles whitespace at the end of a line a configurable option? It this the expected behavior?

Regards,
Eric

3 comments
Comment actions Permalink

What's wrong with clicking on the line and then hitting end?  I can't tell what you're trying to do exactly but it sounds like it might be faster to do all/most of your navigation with just the keyboard.

0
Comment actions Permalink

Hi Eric

Have a look at File / Settings / Editor
There you should see the settings which deal with "Virtual Space" in the editor.
You probably want to uncheck "Allow placement of caret after end of line".

I hope this helps.

Regards, Tony

0
Comment actions Permalink

Hi Tony. That's exactly the setting I was looking for. Thanks.

0

Please sign in to leave a comment.