Unable to add Ruby Interpreter in EAP 535 (OS X)

OS X 10.5.6
EAP 535
Ruby interpreters:
  1.8.6 /usr/bin/ruby
  1.8.7 /opt/local/bin/ruby

When I start RubyMine it picks up the /usr/bin/ruby one, but that doesn't have any gems or anything and I never use it (default installed w/ OS X). I have 1.8.7 installed via MacPorts.

I go to configuration and Ruby interpreter, remove the 1.8.6, and then click add. I can't pick either executable (/usr/bin/ruby or /opt/local/bin/ruby) or a folder or anything. The OK button is disabled and won't enable no matter what I pick in the dialog.  I really like IDEA and want to try this out, but not being able to use my preferred interpreter has me bummed out. Not sure if I can remove the version of ruby that comes with OS X, but that's the next thing I'm going to look in to if I can't get this to work.

3 comments
Comment actions Permalink

Hi,

Thanks for issue! This is a bug and fixed RubyMine EAP will be available tomorrow.

0
Comment actions Permalink

New RubyMine EAP #554  is available

0
Comment actions Permalink

Thanks for the quick response!

0

Please sign in to leave a comment.