RubyMine can't select different versions of rails

I tried to play with RubyMine on MacOS X, but it could only find the default rails installation. I added the path to another version in the preferences panel, but everytime I try to make a new rails project it only finds the default installation and doesn't give me the option to change. Is this a bug or is there another environmental variable I need to adjust.

3 comments
Comment actions Permalink

Think this could be similar to the problem I'm having trying to select different Ruby SDK's.

I've already posted a question on this.

Regards,

Carl

0
Comment actions Permalink

It's not exactly the same because there is an drop down menu that allows you to select the different versions. In the case of different versions of rails there isn't even a drop down menu. I think what's happening is it's just going through the different paths (and there are two default paths) first. If it finds rails then it just stops despite me adding a new path to another installation. So you're not even provided a drop down menu to pick the different versions. It just points to the first and stops.

RubyMine looks promising, so I'm looking forward to a fix. Right now this bug is a blocking me from further testing.

0
Comment actions Permalink

Yes, it's bug. As a temporary solution a can suggest you to use RubyMine with one SDK. If you add the second SDK you should delete the first one.

0

Please sign in to leave a comment.