RubyMine - Configure JRuby SDK

Hi,

I'm trying to configure RubyMine to use the JRuby SDK instead of the native Mac SDK. However, even though I've added and selected the SDK within my project, I can't get the project to use it.

Is this supported?

Regards,

Carl

4 comments
Comment actions Permalink

Hello Carl,

You can use JRuby SDK instead of native Ruby for your projects in RubyMine.
You should add new JRuby SDK and set it as default Ruby interpreter.
Could you please explain your problem more prcisely?

Thanks,
Oleg

0
Comment actions Permalink

OK - How do you add another SDK and set it to default?

I think I've done this correctly but please could you clarify. However, once I add a second SDK i.e. JRuby, both SDK's have the same label so it's hard to identify which is which when I try to select one. e.g. both appear as follows:-

Ruby SDK 1.8.6
Ruby SDK 1.8.6

Once points to my native (Apple) installed Ruby SDK the other points to the JRuby SDK. However, I've tried selecting both of them and but they both always use the native Apple SDK. The JRuby configuration seems to be ignored.

Regards,

Carl

0
Comment actions Permalink

Well, at least your two Ruby interpreters should have different localtions (shown in parens after version of interpreter).
We already have an issue on this problem and this problem will be fixed soon.

Thanks,
Oleg

0
Comment actions Permalink

Thanks Oleg,

Any idea when the fix will be available as would really like to try RM using JRuby?

In the meantime is there a workaround to configure JRuby as the default SDK?

Regards,

Carl

0

Please sign in to leave a comment.