How to make IntelliJ IDEA's plugin work in RubyMine?

I have installed several plugins for RubyMine, but all installed plugins are disabled, and can not work. Any way to make them work?

2 comments
Comment actions Permalink

Hello linux_china,

I`ve created a bug in our bugtracker related to this problem. http://www.jetbrains.net/jira/browse/RUBY-2220

Thanks,
Oleg

0
Comment actions Permalink

Hello linux_china,

I have installed several plugins for RubyMine, but all installed
plugins are disabled, and can not work. Any way to make them work?


Since RubyMine contains only a subset of IntelliJ IDEA's APIs, we do not
load any IntelliJ IDEA plugins automatically - they need to be explicitly
marked as compatible with RubyMine. In order to do that, the developer must
make sure that his plugin builds against the RubyMine libraries, and then
add one of the compatibility markers to plugin.xml. We'll publish an article
detailing these steps later.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.