Rails requires RubyGems >= 0.9.4 (you have 0.9.2)

Hello,

I am trying to use the Ruby/Rails plugin with my Rails 2.0 project. When I try to start the server (Mongrel), I get this error. I don't see where it's getting this version 0.9.2 from. Can anyone help me configure this correctly.

Thanks,
Kannan

4 comments
Comment actions Permalink

I suppose it is a Rails issue. May be you should update your RubyGems.

0
Comment actions Permalink

I suppose it is a Rails issue. May be you should update your RubyGems.

0
Comment actions Permalink

Hello All:

I just tried to update RubyGems from version 0.9.2 to 0.9.4 in terminal on Mac OS 10.4 and I got the following error message:

Permission denied - /usr/local/lib/ruby/gems/1.8/cache/rubygems-update-1.2.0.gem

What to do?

Here's the whole snapshot pasted from terminal:

computer:~/Sites/my_app JPenn$ # display current version
intent-operations-computer:~/Sites/my_app JPenn$ gem -v
0.9.2
computer:~/Sites/my_app JPenn$ # update to the latest version of rubygem
computer:~/Sites/my_app JPenn$ gem update --system
Updating RubyGems...
Bulk updating Gem source index for: http://gems.rubyforge.org
Attempting remote update of rubygems-update
ERROR: While executing gem ... (Errno::EACCES)
Permission denied - /usr/local/lib/ruby/gems/1.8/cache/rubygems-update-1.2.0.gem
icomputer:~/Sites/my_app JPenn$

Thank you in advance for your help!

Best,
Digigumball

0
Comment actions Permalink

Gem package manager requires root privileges, you should use "sudo gem .."

(Also instead of using sudo you can add write permission for /usr/lib/ruby/gems folder)

Edited by: Roman.Chernyatchik on Jul 21, 2008 11:21 AM

0

Please sign in to leave a comment.