How do I make the Ruby plugin work with Cygwin Ruby?

Cygwin puts the exe's in c:\cygwin\bin and the libs in c:\cygwin\lib\ruby. I set my SDK home to be c:\cygwin. I also added c:\cygwin\lib to the SDK's source and class paths. I am able to require some files, but others (rss, timeout) can't be found.

3 comments
Comment actions Permalink

I fixed this by using c:\cygwin\lib\ruby\1.8 instead of c:\cygwin\lib. I also had to add c:\cygwin\lib\ruby\site_ruby\1.8 and c:\cygwin\lib\ruby\gems\1.8. I'm not sure if this is specific to cygwin, but it would be nice if I could just give the lib directory and the plugin would find everything on its own. Also, I have to close and reopen the project each time for the settings to take effect.

0
Comment actions Permalink

Scratch that...it doesn't work for gems. You have to add the src directory of each gem individually :(

0
Comment actions Permalink

Hi, John!

Ruby SDK home is directory that contains subdirectory "bin" with ruby interpreter.(e.g. c:\lang\ruby for c:\lang\ruby\bin\ruby.exe). Ruby plugin asks Ruby interpreter to show gems directories and core libraries. You can also set "Gems bin directory" in SDK settings - it is directory were gems executable are located (e.g. rails, spec, etc). By default "Gems bin directory" is directory where ruby interpreter is located. Usually you shouldn't add or remove other folders in Ruby SDK ClassPath Tab.

---
Best regards, Roman Chernyatchik.

0

Please sign in to leave a comment.