Update to IDEA 2016.1.2(b?) failing on Linux, no space on /tmp device?


Tried to install the second  IDEA 2016.1.2 update this morning and its failed twice for me. Each time it claims the /tmp device is full but it doesn't look full before or after the updates?

$ df -h
Filesystem Size Used Avail Use% Mounted on
8.8G 5.5G 2.9G 66% /
tmpfs 1.9G 72K 1.9G 1% /dev/shm
/dev/vda1 976M 167M 758M 19% /boot
2.9G 21M 2.8G 1% /tmp
4.8G 3.6G 1010M 79% /home
49G 31G 16G 68% /opt
4.8G 295M 4.3G 7% /var/lib/mysql
java.io.IOException: No space left on device
at java.io.FileOutputStream.writeBytes(Native Method)
at java.io.FileOutputStream.write(FileOutputStream.java:326)
at java.io.BufferedOutputStream.write(BufferedOutputStream.java:122)
at ie.wombat.jbdiff.JBPatch.bspatch(JBPatch.java:149)
at com.intellij.updater.BaseUpdateAction.applyDiff(BaseUpdateAction.java:112)
at com.intellij.updater.UpdateAction.doApply(UpdateAction.java:44)
at com.intellij.updater.PatchAction.apply(PatchAction.java:184)
at com.intellij.updater.Patch$3.forEach(Patch.java:308)
at com.intellij.updater.Patch.forEach(Patch.java:360)
at com.intellij.updater.Patch.apply(Patch.java:303)
at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:84)
at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:75)
at com.intellij.updater.Runner.doInstall(Runner.java:280)
at com.intellij.updater.Runner.access$000(Runner.java:17)
at com.intellij.updater.Runner$1.execute(Runner.java:246)
at com.intellij.updater.SwingUpdaterUI$5.run(SwingUpdaterUI.java:191)
at java.lang.Thread.run(Thread.java:745)

$ lsb_release -d
Description: CentOS release 6.7 (Final)

$ java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)


Comment actions Permalink

Is there some other way to apply the patch but change the /tmp directory it uses? don't think I can extend my /tmp how big is this patch? >3GB?

Comment actions Permalink

Is there something in this particular update that needs 3GB+ free in /tmp or will I have to keep downloading full releases for every minor update from now on because IDEA Ultimate has grown so large? E.g. I can't get IDEA ultimate without Kotlin?

Is there a min required size on /tmp partition for using IDEA? how big should it be?


Comment actions Permalink

There is some Linux specific bug that reports wrong free space size. 1GB should be fine.

Kotlin can be disabled: http://www.jetbrains.com/idea/webhelp/enabling-and-disabling-plugins.html.

Comment actions Permalink

Some linux bug reporting the wrong size, but I've been using this same VM for years I've .IntellijIDEA12,13,14,15 and now 2016.1 installations folders on it and Oracle Java 7 VM u45 that's not a new install either. Why has this mysterious bug hit on this one update and none of the other countless past ones? including the first 2016.1.2 just update last week - why another 2016.1.2 and not 2016.1.3?

It failed, so I cleaned out /tmp as much as possible (wasn't nearly full) so had 2.9GB free ran again and it still failed. I'm guessing it copies my IDEA2016 install folder to /tmp, unpacks the update, runs the update on the /tmp copy of IDEA and if successful replaces that patched with the original copy? 

The ticket you've linked this to doesn't state the version (raised 2014), but they only had 500MB /tmp which seems small, 3GB should be sufficient - there's no mention of any faulty filesystem freespace reporting?

Only mentioned Kotlin as it's bumped up the size of the 2016 ultimate installation folder, its the second of the three largest plugins bundled with IDEA and all three are ones I don't (knowingly) use nor plan to. Disabling them won't help size/update wise.

Comment actions Permalink

Managed to get this update to work. TLDR; /tmp isn't /tmp its (~/.IntelliJIdea2016.1/system/) see https://youtrack.jetbrains.com/issue/IDEA-122925.

Though jetbrains might think about adding some previous version housecleaning to their major updates? if not fixing the misleading error messages from the updater.

Comment actions Permalink

Same 'no space on device' failure when I tried to install 2017.2 update today, guess no progress was made on this in the last year. 

df -h says I have 2.7GB free on this device.

Comment actions Permalink

I got this error as well after upgrading to 2017.2. But actually it was related to my space. I had 14GB worth log files in my source folder which I haven't cleared for a while. But after cleaning it it now works normally. Cheers!.


Please sign in to leave a comment.