Disable light bulb

Answered

I try to click on something on the left side of a file and a light bulb pops up with some selections, and they're usually different depending on the line I'm on. I see how to disable each little intention or inspection or whatever, but I just want the light bulb to go away.

I don't care if PHPStorm scans the code for issues, I just need to get these pop-ups out of the way without disabling code validation or manual suggestions (like Ctrl+Space).

12 comments
Comment actions Permalink

It says "No Affected versions" and "Declined", so does that mean JetBrains thinks it's not a problem and won't fix it anyways?

0
Comment actions Permalink

Please read comments as well -- very often they have a lot of value.

1. Why "declined" -- https://youtrack.jetbrains.com/issue/IDEA-94381#comment=27-565622

2. Possible workaround (not sure if it still works or not) -- https://youtrack.jetbrains.com/issue/IDEA-94381#comment=27-566062

1
Comment actions Permalink

Can confirm that this workaround is fine - tested it recently.

0
Comment actions Permalink

How is "providing a setting to turn the bulb off" a "bad idea"?

1
Comment actions Permalink

Also I don't know where $IDE_CONFIG_HOME/options/editor.xml is

0
Comment actions Permalink

This light bulb is very annoying because of its position on the left of the line. Very often it interferes with the line selection which I happen to do often. Why is there a need to "work around"? There must be a setting to turn that off. Thanks.

0
Comment actions Permalink

Oh sorry to mention the environment: IDEA 2016.2.4, Community Edition, Scala editor.

0
Comment actions Permalink

Please leave corresponding feedback at https://youtrack.jetbrains.com/issue/IDEA-94381 so the devs could hear you.

0
Comment actions Permalink

In the workaround it mentions $IDE_CONFIG_HOME. I found at my user home directory, there was .PhpStorm2016.3\config\options

there was no editor.xml file there, so after some researching on the Internet, I created it with the following content:

<application>
<component name="EditorSettings">
<option name="SHOW_INTENTION_BULB" value="false" />
</component>
</application>

and then restarted PHPStorm. It's working now, and to evoke the functionality, I hit Alt + Enter.

0
Comment actions Permalink

You can now disable it from the Preferences window now. Thanks, JetBrains!

4
Comment actions Permalink

great, thank you! :)

1

Please sign in to leave a comment.