Remote run in Eclipse shows "No suitable modified files found for Remote Run"

I use Eclipse and git. Egit and Teamcity eclipse plugins are installed. Egit does work well. However, after commit a local change, click "remote run" shows a dialog saying "No suitable modified files found for remote run".

I've set up a build configuration on TeamCity whose VCS is the root of the repository holding the changed file. And I'm sure I haven't pushed it yet.

Question, is there any special setting or configuration on TeamCity build configuration to make it happen? Currently I set "Branch Remote Run Trigger" and git pattern is "refs/heads/remote-run/*". And I tried commit change from "TeamCity Local Changes" and Project Explorer->Team->Commit. Neither works.

Thanks!

4 comments

What version of TeamCity do you use?

BTW, for the future please use TeamCity forum for TeamCity related questions: http://devnet.jetbrains.com/community/teamcity

0

Hi Pavel,

My TeamCity is TeamCity Enterprise 7.1.4 (build 24331). I've forward this question to TeamCity forum. Thanks.

Cathy

0

There was one similar fix in 8.0, see: http://youtrack.jetbrains.com/issue/TW-28654
Please try upgrading to this version.

0

I'm also getting same error message with my eclipse-kepler and VCS-SVN, what is the solution pls guide.

0

Please sign in to leave a comment.