Bundled XSLT Debugger plugin in IDEA 11: JDK 1.6 only?

I just downloaded IDEA 11, and my overall impression is very positive. I initially was pleased to hear that the XSLT Debugger plugin comes now bundled with IDEA. This plugin is vital for my current work.

Now there's one severe problem for me: The bundled XSLT Debugger plugin does only work on a 1.6 JDK. When I try to use it with the 1.5 JDK I develop for, I get an UnsupportedClassVersionError on org/intellij/plugins/xsltDebugger/rt/XSLTDebuggerMain. However, using a 1.6 JDK isn't an option.

Is it somehow possible to run this new plugin version on a JDK 1.5, or do I have to stay with IDEA 10?

Thanks.

6 comments

Hello Felix,

unfortunately, the runtime classes of the debugger have been compiled with Java 1.6, so the currently released version will only with 1.6 or later. I'm investigating how to change this for the next release.

If it's really important for you, I can send you a locally built version that should run with Java 1.5 as well.

BTW: Why can't you just run the debugged stylesheets with a JDK 1.5 (can be changed in the xslt run configuration's Advanced tab)? Do you use custom extensions or java functions from your stylesheets?


Cheers,
Sascha
0

Hello Sascha,


BTW: Why can't you just run the debugged stylesheets with a JDK 1.5 (can be changed in the xslt run configuration's Advanced tab)?

This is exactly what I'm doing. My advanced configuration is:

VM Arguments: -Dxslt.transformer.type=xalan
(To use the Xalan instead of Saxon; the problem persists if I clear this field)

[X] Use JDK = JDK 1.5

With this configuration, the Java runner from the JDK 1.5 is used and crashes if I try to debug the configuration. IDEA itself runs on a JRE/JDK 1.6; I didn't state that clearly in my first post.

I'll be happy if the next release contains an XSLT debugger working with 1.5, thanks for your effort.

Cheers,
Felix

0

Hello Felix,

I'm sorry, of course I meant to explicitly switch to JDK 1.6 in the advanced tab if your project's JDK is 1.5.

Selecting a JDK would not work if you're using code from your project's or module's classpath in the stylesheet. However, since you already selected a "plain" JDK (1.5), I think you should be able to select 1.6 for the XSLT runner without problems.

Cheers,
Sascha

0

Hello Sascha,

to give you an impression of the problem:

The 1.5 JDK I deploy on and test with is from IBM, as distributed with their WebSphere application server. The Xalan included there is not the current official version 2.7.1, but customized by IBM. The most prominent change for me is that this bug is fixed. Some of my stylesheets depend on this fix. Therefore, I cannot use the standard JDK 1.6 as distributed by Sun/Oracle, which includes Xalan 2.7.1.

Cheers,
Felix

0

OK, I see. Maybe you can try to set the system property java.endorsed.dirs (as JVM argument on the Advanced tab) to a directory that contains the version of Xalan you depend on. That way you should be able to select a "normal" JDK 1.6 and still use the fixed version of Xalan (as long as this doesn't depend on any IBM-specific stuff).

Cheers,
Sascha

0

Nice one. I copied the jar including the Xalan to an empty directory xmllib and added -Djava.endorsed.dirs=D:\java\xmllib to the VM parameters. With this, I'm able to debug my stylesheets with IBM's Xalan on JDK 1.6. Thanks a lot!

Cheers,
Felix

0

Please sign in to leave a comment.