Can't run build with custom ant

I try to run build with ant 1.8.0, I choose my ant installation dir and choose "Use custom ant" in Ant Build properties.
When I run build I got this output:

/usr/lib/jvm/java-6-sun/bin/java -Xmx128m -Xss32m -Dant.home=/usr/share/ant -Dfile.encoding=UTF-8 -classpath /usr/share/ant/lib/ant-apache-log4j.jar:/usr/share/ant/lib/ant-apache-bcel.jar:/usr/share/ant/lib/ant-junit.jar:/usr/share/ant/lib/ant-
nodeps.jar:/usr/share/ant/lib/ant-jsch.jar:/usr/share/ant/lib/ant-apache-xalan2.jar:/usr/share/ant/lib/ant-jdepend.jar:/usr/share/ant/lib/ant-commons-logging.jar:/usr/share/ant/lib/ant-antlr.jar:/usr/share/ant/lib/ant-swing.jar:/usr/share/ant/lib/ant-apache-
resolver.jar:/usr/share/ant/lib/ant-apache-bsf.jar:/usr/share/ant/lib/ant-apache-oro.jar:/usr/share/ant/lib/ant-apache-regexp.jar:/usr/share/ant/lib/ant-jmf.jar:/usr/share/ant/lib/ant-trax.jar:/usr/share/ant/lib/ant-
launcher.jar:/usr/share/ant/lib/ant.jar:/usr/share/ant/lib/ant-commons-net.jar:/usr/share/ant/lib/ant-stylebook.jar:/usr/share/ant/lib/ant-javamail.jar:/usr/lib/jvm/java-6-sun/lib/tools.jar:/opt/IntelliJ/idea/lib/idea_rt.jar
com.intellij.rt.ant.execution.AntMain2 -logger com.intellij.rt.ant.execution.IdeaAntLogger2 -inputhandler com.intellij.rt.ant.execution.IdeaInputHandler -buildfile /home/username/projects/tester/build.xml productionDeploy
build.xml
/home/username/projects/tester/build.xml:2: Unexpected element "{}HTML" {antlib:org.apache.tools.ant}HTML
       at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:288)
       at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:177)
       at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:80)
       at org.apache.tools.ant.Main.runBuild(Main.java:786)
       at org.apache.tools.ant.Main.startAnt(Main.java:218)
       at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
       at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at com.intellij.rt.ant.execution.AntMain2.main(AntMain2.java:32)
Caused by: org.xml.sax.SAXParseException: Unexpected element "{}HTML" {antlib:org.apache.tools.ant}HTML
       at org.apache.tools.ant.helper.ProjectHelper2$MainHandler.onStartChild(ProjectHelper2.java:658)
       at org.apache.tools.ant.helper.ProjectHelper2$RootHandler.startElement(ProjectHelper2.java:565)
       at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
       at org.cyberneko.html.HTMLTagBalancer.callStartElement(HTMLTagBalancer.java:1126)
       at org.cyberneko.html.HTMLTagBalancer.startElement(HTMLTagBalancer.java:734)
       at org.cyberneko.html.HTMLTagBalancer.forceStartElement(HTMLTagBalancer.java:758)
       at org.cyberneko.html.HTMLTagBalancer.startElement(HTMLTagBalancer.java:618)
       at org.cyberneko.html.HTMLTagBalancer.forceStartElement(HTMLTagBalancer.java:758)
       at org.cyberneko.html.HTMLTagBalancer.startElement(HTMLTagBalancer.java:586)
       at org.cyberneko.html.HTMLTagBalancer.forceStartElement(HTMLTagBalancer.java:758)
       at org.cyberneko.html.HTMLTagBalancer.startElement(HTMLTagBalancer.java:618)
       at org.cyberneko.html.filters.DefaultFilter.startElement(DefaultFilter.java:136)
       at org.cyberneko.html.filters.NamespaceBinder.startElement(NamespaceBinder.java:278)
       at org.cyberneko.html.HTMLScanner$ContentScanner.scanStartElement(HTMLScanner.java:2697)
       at org.cyberneko.html.HTMLScanner$ContentScanner.scan(HTMLScanner.java:2013)
       at org.cyberneko.html.HTMLScanner.scanDocument(HTMLScanner.java:907)
       at org.cyberneko.html.HTMLConfiguration.parse(HTMLConfiguration.java:499)
       at org.cyberneko.html.HTMLConfiguration.parse(HTMLConfiguration.java:452)
       at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
       at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
       at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
       at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:275)
       ... 11 more

Ant build completed with one error one warning in 0s at 7:05:30 PM


And no build is runned. When I start ant from console all is ok - build run as expected.
build.xml starts with:

<?xml version="1.0" encoding="UTF-8"?>
<project name="tester" default="run">
<!--...-->
</project>


What I do wrong? or maybe it is a bug?


Thanks.

Please sign in to leave a comment.