GWT plugin for Intellij 7

I am using intellij 7.0.4. We need to develop an application using the GWT framework so i tried to figure out a good plugin in intellij but the only thing i could find is GWT Studio ver 1.0 in the Installed plugin list. Now we like to carry out development on latest GWT ver 2.0 but when i tried to give the Path to GWT installation directory (ver 2.0 dir ) it gives me an error that this is not a valid installation and gwt-dev-windows.jar not found (image attached). I am not able to compile the classes like EntryPoint etc which is obvious because the intellij GWT Studio plugin is not mapping correctly to GWT 2.0. Is there any way i could use GWT 2.0 with Intellij 7

Also when i give the Path to GWT installation directory to GWT old , deprecated version 1.0.21 the plugin maps correctly but i dont want to work on the deprecated version of GWT.

Is there any GWT 2.0 plugin that works with Intellij

OR

Whats the latest GWT plugin version i can work with Intellij 7



Attachment(s):
intellij_gwt_error.JPG
2 comments

Hello Fahad,

The GWT plugin is now part of the IntelliJ IDEA distribution, and all new
development happens as part of the regular IntelliJ IDEA development. To
get support for the latest GWT version, you'll need to upgrade to IntelliJ
IDEA 9.

I am using intellij 7.0.4. We need to develop an application using the
GWT framework so i tried to figure out a good plugin in intellij but
the only thing i could find is GWT Studio ver 1.0 in the Installed
plugin list. Now we like to carry out development on latest GWT ver
2.0 but when i tried to give the Path to GWT installation directory
(ver 2.0 dir ) it gives me an error that this is not a valid
installation and gwt-dev-windows.jar not found (image attached). I am
not able to compile the classes like EntryPoint etc which is obvious
because the intellij GWT Studio plugin is not mapping correctly to GWT
2.0. Is there any way i could use GWT 2.0 with Intellij 7

Also when i give the Path to GWT installation directory to GWT old ,
deprecated version 1.0.21 the plugin maps correctly but i dont want to
work on the deprecated version of GWT.

Is there any GWT 2.0 plugin that works with Intellij

OR

Whats the latest GWT plugin version i can work with Intellij 7


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Hi Dmitry

What are my options if I want to stick to Intellij 7 ?

a) Should I have to work on GWT 1.0.21

b) Can some how GWT later version 1.6 , 1.7 or 2.0 be plugged in intellij 7

c) any other option

0

Please sign in to leave a comment.