Findbugs IDEA 0.9.9 Broken

Previous version of the findbugs plugin worked great for me. I updated to Findbugs IDEA 0.9.9 and now get the error shown in the screen shot.

(This is with 9 M1)

Screen shot 2009-09-23 at 9.17.29 AM.png


I also tried going to Project Structure->Modules->Findbugs-IDEA tab and selected "Override FindBugs-IDEA project settings", that had to affect on its behavior.

Can anyone provide any insight? Do you have to do some configuration before you can use it?

0
6 comments

try to set the defaults in the configuration panel (Settings->findbugs-IDEA not  Project Structure->Modules->Findbugs-IDEA tab). "restore defaults" button and than press "apply" as workaround. feel free to file it issue tracker. thanks.  could you please attach or send by mail your project .ipr and .iml file or check them for an entry like

<component name="org.twodividedbyzero.idea.findbugs">
...
...
...
</component>

0

If using the defaults doesn't work I can say for sure that 0.9.84-dev works in Maia 10781.
Though I might have had to change the allowed version string in the Plugin JAR so it would work with builds higher than 9999

0

in main configuration settings not in the module settings, what does the detector tab show? an empty table? or checked detectors? any findbugs <component> entry in the *iml or *ipr file?

0

Restoring the defaults did the trick. I did not see that button before as I didn't notice that all of the panel wasn't beingshown, I had to scroll to see that button.

0

Version 0.9.91 should fix the issue concerning "first time inititiating default preferences"

0

rob, any exceptions?

maybe something like?

java.lang.InternalError: Memory Pool not found
        at sun.management.MemoryPoolImpl.getPeakUsage0(Native Method)
        at sun.management.MemoryPoolImpl.getPeakUsage(MemoryPoolImpl.java:82)
        at edu.umd.cs.findbugs.Footprint$MemoryBeanWrapper.getPeakUsage(Footprint.java:120)

0

Please sign in to leave a comment.