GAE local_db.bin Deleted

Google app engine creates a

local_db.bin file when you store data in the datastore.  The file gets created in "out/exploded/gae2Web/WEB-INF/appengine-generated" directory.  It works fine for each individual run, but when the app is rebuilt, the file gets deleted.  This means any data stored also gets deleted.


How can I keep data between runs of the Google App Engine?  I am also running the GAE under the GWT plugin, so that I am able to debug client code.

This issue makes the debugging an application very difficult, and would keep me developing on Intellij if it is not fixed.

Thanks,
Jeffrey Goetsch
3 comments
Comment actions Permalink

I cannot reproduce the problem. How do you rebuild the project? Do you use Build | Rebuild Project action or something else?

Google app engine creates a local_db.bin file when you store data in the datastore. The file gets created in "out/exploded/gae2Web/WEB-INF/appengine-generated" directory. It works fine for each individual run, but when the app is rebuilt, the file gets deleted. This means any data stored also get
s deleted.


How can I keep data between runs of the Google App Engine? I am also running the GAE under the GWT plugin, so that I am able to debug client code.

This issue makes the debugging an application very difficult, and would keep me developing on Intellij if it is not fixed.

Thanks,
Jeffrey Goetsch

---
Original message URL: http://www.jetbrains.net/devnet/message/5243899#5243899



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Nikolay,

Sorry it has taken me so long to reply, but I have spent more time tracking down the problem and think I know the issue.

When I run my project as GAE debug, everything works fine.  The local_db.bin file is produced and works correctly.  I am able to relauch and it uses the existing data.

When I try and run it from a GWT debug by passing in the "-server com.google.appengine.tools.development.gwt.AppEngineLauncher" option into the shell parameters, I am able to get the program to run and access the datastore, but it doesn't seem to access the local_db.bin file created with GAE debug.  If I delete the file, it is not created by the GWT debug process.  I don't understand the difference or how to make the GWT debug persist the datastore to a file or access a file that already exitst.

If possible, please explain how to run the GWT debug, but still access the GAE server.

Thanks,
Jeff

PS If is helps I can email my project with to you.

0
Comment actions Permalink

I've reproduced the problem. Could you please create a Jira issue for this bug (http://jetbrains.net/jira/browse/idea)?

Nikolay,

Sorry it has taken me so long to reply, but I have spent more time tracking down the problem and think I know the issue.

When I run my project as GAE debug, everything works fine.  The local_db.bin file is produced and works correctly.  I am able to relauch and it uses the existing data.

When I try and run it from a GWT debug by passing in the "-server com.google.appengine.tools.development.gwt.AppEngineLauncher" option into the shell parameters, I am able to get the program to run and access the datastore, but it doesn't seem to access the local_db.bin file created with GAE debug.  If I delete the file, it is not created by the GWT debug process.  I don't understand the difference or how to make the GWT debug persist the datastore to a file or access a file that already exitst.

If possible, please explain how to run the GWT debug, but still access the GAE server.

Thanks,
Jeff

PS If is helps I can email my project with to you.

---
Original message URL: http://www.jetbrains.net/devnet/message/5244670#5244670



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.