<idea-version/> syntax?

Hi all,


I recently uploaded a plugin to the public repository. It is listed on the website but it not listed with I browser the plugin repository from within IDEA.

What I noticed is that the compatible builds mentioned on the website is 40.133 . My guess it is an invalid build version. The plugin.xml contains <idea-version since-build="133"/> yet it becomes 40.133.

I read http://www.jetbrains.org/intellij/sdk/docs/basics/getting_started/build_number_ranges.html but I'm still not 100% clear on the syntax. Other posts I read on this website mention 133 as value. I now wonder whether that should 133.0 but the documentation just mention branch XYZ without explicitly mentioning the acceptable since-build.

Should it simply be 133.0? Or is there a review process before the plugin appears within IDEA itself.

Bit confused. :(  Any help is much appreciated :)

Best regards,

Johan

ps: it this can help the plugin is here in the repo

2 comments
Comment actions Permalink

If your plugin is compatible with IntelliJ IDEA 13 and later, the since-build should be 133.0.


0
Comment actions Permalink

All good now.

Thank you very much Dmitry!

Johan

0

Please sign in to leave a comment.