Ruby Editor Quirk, and Question about installing plugins

Noticed this both in IntellijIDEA 8.1 and in the new RubyMine 90 day preview: basically, the syntax highlighting tool isn't working for "require or load call" elements. Once you switch one time to cobalt or vibrantink themes, going back to default reproduces this problem (at least it does for me on both my Windows and my Mac installtions). You will observe that the background behind "require" and "load" remains darkened and clicking on the keywords in the tool in either window does not appear to "work"... and making any changes to the highlighting rules have no effect either in the tool or in the editor after you try to apply them. see screenshots.

Also, is there a way to install existing plugings? This has frustrated me a bit -- even if I had the ability to type in a console or something. Even better, a way to define "typical plugins" I always use so they get installed automatically if I select them in the wizard -- that would be a real time saver.

Thanks!

- Bob



Attachment(s):
ruby-highlighting-errors-2.jpg
ruby-highlighting-errors.jpg
1 comment
Comment actions Permalink

OK I found the "Run Rails Script" but to describe it as spartan would be an exaggeration.

But at least there is a way. It's not exactly super intuitive, but I'm sure once I fiddle with it I'll figure it out...

- Bob

0

Please sign in to leave a comment.