Flex compiler error

Hi!
I'm getting an "Error: Cannot determine version for JDK flex_sdk_3. Update JDK configuration."
Where flex_sdk_3 -  flex sdk :-)
It happens on both Centos & Mac.  Idea 8.01
I use IDE builder with a config file like this:

<flex-config><!-- xmlns="http://www.adobe.com/2006/flex-config">-->
    <compiler>
        <debug>true</debug>
        <source-path>
            <path-element>./src</path-element>
        </source-path>
        <include-libraries>
            <library>/Users/myname/Kanban/KanbanCommon/libs/as3corelib.swc</library>
            <library>/Users/myname/Kanban/KanbanCommon/libs/cairngorm.swc</library>
        </include-libraries>

    </compiler>
    <static-link-runtime-shared-libraries>true</static-link-runtime-shared-libraries>
    <!--<file-specs>
        <path-element>src/KanbanMain.mxml</path-element>
    </file-specs>-->
    <include-classes>
        <class>com.tacitknowledge.KanbanMain</class>
    </include-classes>
    <output>./build/common.swc</output>
</flex-config>


It used to work before. But now it doesn't (( What it could be?

1 comment
Comment actions Permalink

Solved. My fault because of a usability problem((
In  project tree New=>Class should be New=>"Java Class". Or should be overrided in flex module to create Flex class.

0

Please sign in to leave a comment.