GWT Plugin Annoying Error

I'm using the GWT Plugin but basically for syntax checking and debugging. The files are compiled with an Ant script I wrote myself, it is part of a larger project so this is necessary.

It works fine so far, my only issue is IDEA (7.0.3) complaining all the time, that:

"Class java.lang.String is not present in the JRE Emulation Library so it can not be use in client code"

This is just wrong, it all works fine (with GWT 1.5 RC2). How do I fix this?

3 comments
Comment actions Permalink

I'm using version 15.0.2 and I still have this annoying bug. Any hint to get rid of it?

 

1
Comment actions Permalink

Hello mh,

Note that the latest version of IDEA is 7.0.4. I don't remember if it fixes
this specific problem, but you should upgrade in any case because of many
other important fixes.

I'm using the GWT Plugin but basically for syntax checking and
debugging. The files are compiled with an Ant script I wrote myself,
it is part of a larger project so this is necessary.

It works fine so far, my only issue is IDEA (7.0.3) complaining all
the time, that:

"Class java.lang.String is not present in the JRE Emulation Library so
it can not be use in client code"

This is just wrong, it all works fine (with GWT 1.5 RC2). How do I fix
this?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I am using Idea 7.0.4, but am having a simular problem. I have moved model classes to a different module, but in a class that is acceptable to the compiler. Idea does compile the code without errors, and the project runs without problems.

Idea does however mark every use of the classes moved outside the module as errors.

0

Please sign in to leave a comment.