Guide to pythonid?

I just installed the pythonid plugin on IDEA 7.0.4, but I don't understand how to use it.

I expected to see New Module...->Python Module, but it isn't there.

Where's the doc?

Thanks!

3 comments
Comment actions Permalink

Hello Andrew,

I just installed the pythonid plugin on IDEA 7.0.4, but I don't
understand how to use it.

I expected to see New Module...->Python Module, but it isn't there.

Where's the doc?


There isn't any. The Pythonid version currently available in the plugin manager
provides very limited functionality. You'll have to use a Java module type
for your Python application, and you only get pretty much basic editing support
for *.py files.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I cannot figure out how to call Java subroutines located in a different module than my python script.

I have a ZythonGlue module with the class zython.util.Truthiness, and a Zython module with the script TestTruthiness.py starting with these lines:

from zython.util.Truthiness import isTrue
from zython.util.Truthiness import isFalse

When I run TestTruthiness.py, I get "ImportError: No module named zython.util.Truthiness".

In my Zython module Project Settings, I have ZythonGlue listed in the Dependencies tab.

What else do I need to do?

Thanks!

--Andrew Mickish

0
Comment actions Permalink

Hello Andrew,

I cannot figure out how to call Java subroutines located in a
different module than my python script.

I have a ZythonGlue module with the class zython.util.Truthiness, and
a Zython module with the script TestTruthiness.py starting with these
lines:

from zython.util.Truthiness import isTrue
from zython.util.Truthiness import isFalse
When I run TestTruthiness.py, I get "ImportError: No module named
zython.util.Truthiness".

In my Zython module Project Settings, I have ZythonGlue listed in the
Dependencies tab.

What else do I need to do?


You need to wait for the release of the Python plugin for IDEA 8. The version
of the plugin currently available in the plugin manager does not support
this scenario.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.