Can't install any plugins

I can't seem to install any plugins whatsoever from either the new iMac I just set up, or my existing installation of 7.0.3 on the MacBook Pro. Whenever I try to install any plugin (and I mean any plugin...doesn't matter which one), IDEA throws up an error saying "error opening zip file".

I know network connectivity is fine, as it reloads the list of available plugins just fine and I can hit the plugins.intellij.net website with a browser (and even download the plugins individually). But for some reason plugin installation isn't happening at all on either machine.

I started using JDK 1.6 (the Apple 64-bit version) for the performance improvements and thought maybe this was the cause. I switched it back to JDK 1.5 and still same result: "error opening zip file".

There is no traceback that I can see and I don't see any logging done by the IDE anywhere (a la eclipse's .log file). Any pointers here would be greatly appreciated.

BTW- Running OS X Leopard 10.5.4 and Java 1.5.0_13 (also tried with 1.6.0_5).

5 comments
Comment actions Permalink

I am working with a colleque, we're both experiencing similar problems. I'm running 7.0.3 intellij on XP java 1.6_05, she's running 7.03 IntelliJ on Mac OS X 10.4 java 1.5 , she gets the 'error opening zip file', I'm getting '

Plugin JetGroovy not installed: the filename, directory name, or volume label syntax is incorrect.

Tried the dilbert plugin, it's broken as well.

Tried the cafebabe, it's broken as well

Went to code.google.com and downloaded the cafebabe plugin, manually unzipped and put in my plugins folder and it worked.

So I'm guessing this is a problem on the server end?

Edited by: smudgy on Jul 31, 2008 11:41 PM

0
Comment actions Permalink

I got working by going to this page and installing 1.5.17497.

http://plugins.intellij.net/plugin/?id=1524

The 1.6.17490. version produces a similar error. I suspect that the download page is giving the (older?? numbers backwards??) version, or somebody didn't rollback a broken version or somethign

0
Comment actions Permalink

I also got this to work (finally) by rolling back Groovy to 1.5.

Why would the 2.0 version even install in IDEA 7 if it's specific to IDEA 8?

Maybe this will also fix my GWT compiler problem? I'll try it...

0
Comment actions Permalink

Not really a solution, but on the MacBook Pro I deleted my install of IDEA 7, including everything I could find related to it; preferences, caches, application support. I re-downloaded 7.0.3 and installed and was able to install the plugins.

0
Comment actions Permalink

I know this thread is 10 years old, but I recently had a similar problem and found a solution.

The problem was that when I tried to "Install a Plugin from Disk", all the .zip files for Plugins were greyed out. They had worked a few days previously.

The issue was that my JDK was not setup correctly. When fiddling with some other stuff, I selected an "unstable" JDK. You may see this warning when you startup IntelliJ if you have an unstable JDK (although it seems 99% of the features still work). The solution was to choose a better JDK.

0

Please sign in to leave a comment.