(urgent)struts2 doesn't work in the Intellij7.0.3

I added the struts2 plugin in the intellij7.0.3, i configured it in the project setting and ran it. But
the intellij gave me wrong info..I don't know what's the problem?
Please! Thanks a lot.

struts version:2.0.11.1
wrong info. as following:


update failed for ActionGroup: anima.plugins.api.ActionAdapter@13a5f6a[Open Struts Configuration Wizard]: WEB
java.lang.NoSuchFieldError: WEB
at anima.plugins.api.PathManager.getWebModules(PathManager.java:83)
at anima.plugins.struts.G.K.checkEnabled(y:54)
at anima.ui.action.SmartAbstractAction.update(SmartAbstractAction.java:59)
at anima.plugins.api.ActionAdapter.update(ActionAdapter.java:42)
at com.intellij.openapi.actionSystem.impl.Utils.a(Utils.java:82)
at com.intellij.openapi.actionSystem.impl.Utils.expandActionGroup(Utils.java:29)
at com.intellij.openapi.actionSystem.impl.ActionToolbarImpl.updateActionsImmediately(ActionToolbarImpl.java:213)
at com.intellij.openapi.actionSystem.impl.ActionToolbarImpl$MyTimerListener.run(ActionToolbarImpl.java:14)
at com.intellij.openapi.actionSystem.impl.WeakTimerListener.run(WeakTimerListener.java:6)
at com.intellij.openapi.actionSystem.impl.ActionManagerImpl$MyTimer.a(ActionManagerImpl.java:1)
at com.intellij.openapi.actionSystem.impl.ActionManagerImpl$MyTimer.actionPerformed(ActionManagerImpl.java:14)
at javax.swing.Timer.fireActionPerformed(Timer.java:271)
at javax.swing.Timer$DoPostEvent.run(Timer.java:201)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:131)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:132)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:136)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

8 comments
Comment actions Permalink

Deinstall incompatible version of Struts Assistant plugin

0
Comment actions Permalink

Then what's the version of struts assistant plugin I should install in the intellij7.0.3?
pls,Thanks v much Yann.

0
Comment actions Permalink

You don't need to install Struts Assistant manually as it's shipped with IDEA 7

0
Comment actions Permalink

Thanx for your reply, Yann. My meaning is that the struts assistant plugin's version shipped with in the intellij7.0.3 is 1.0.7, if I use this plugin, the problem above will arise. But I uninstall this plugin, the intellij will have no function of struts assistant. So how can i deal with this problem? And how can i upgrate the version of struts assistant plugin in the intellij7.0.3?
Thanks.

Edited by: Andy on Jun 26, 2008 12:45 PM

0
Comment actions Permalink

Simply reinstall into a different directory, so you can copy $IDEA_HOME$/plugins/StrutsAssistant-folder into old location

0
Comment actions Permalink

I deinstall the plugin and use the SA shipped with Intellij7, but when run the project, no Struts Assistant window to show the structure of struts files and configure, so how can i deal with this problem?
Thanks.

0
Comment actions Permalink

I got it, Thanx Yann!

0

Please sign in to leave a comment.