# 8375 - Valid code flagged as error

Using JDK 1.5.0_12, I'm subclassing a JTabbedPane, and overriding the createChangeListener() method to return a custom ModelListener, and the ModelListener constructor is being flagged as an error - IDEA thinks it should take a JTabbedPane argument. The code compiles OK and runs as expected. In the JDK source file for JTabbedPane, the createChangeListener method (that I'm overriding) itself uses the default ModelListener constructor.

The other odd thing is that when I hit Ctrl-B on the ModelListener constructor, IDEA takes me to the JTabbedPane class file, where the ModelListener constructor apparently does take a JTabbedPane argument...(!) - Both the JTabbedPane source file and the class file are clearly in JDK 1.5.0_12 (in src.zip and rt.jar respectively).

This project file hasn't given this error before in previous versions of IDEA, and hasn't changed for some time.

I'm confused - can anyone enlighten me?

2 comments
Avatar
Eugene Vigdorchik
Comment actions Permalink

Looks like (and I believe it is the same) http://www.jetbrains.net/jira/browse/IDEADEV-26725

0
Comment actions Permalink

Yup, that looks like it - and it's fixed already :)

Thanks Eugene - well spotted.

0

Please sign in to leave a comment.