Plugin Issues with Intellij Ubuntu

I'm working on a language plugin for perl and it's going really well.
When I develop it on windows - all the features works fine.
When I Install and use it on windows - all the features works fine.
When I develop it on ubuntu - all the features works fine.
When I Install and use it on ubuntu - only a minimal set of features works.

I'm running intellij 14.1.3

Even the fileTypeFactory doesn't work, any help would be appreciated.




Thanks in advance

Comment actions Permalink

Please make sure that you don't have an old version of your plugin with the same ID in a different directory in your Ubuntu installation.

Comment actions Permalink

Thanks for the quick reply Dmitry Jemerov,

Unfourtunatly your suggestion didn't work.

Steps i took:
1.I've removed all the jars from my system and uninstalled the plugin through intellij.
2.changed the id in the META-INF to com.intellij.perlplugin and "prepared the plugin".
3.installed the plugin and restarted Intellij

- File icons still doesn't show as well as syntax highlighting and autocompletion.
- Create new Perl Project/Module, Create New Perl File and Add new Perl SDK works.
- The Icon is working for the Create New Perl action so I'm confident the icon file isn't currpoted

Comment actions Permalink

Please check Settings | File Types and make sure that the .pl extension is mapped to your file type and not to Text File.

Comment actions Permalink

That worked! Thanks Dmitry Jemerov.
Is there a way to make this configuration automatic upon installing the plugin?

Comment actions Permalink

This will be configured automatically if the user has no pre-existing mapping for the .pl extension. If the mapping exists, recent versions of IntelliJ IDEA will show a notification offering the user to change it.


Please sign in to leave a comment.