Using packages with custom xml base components in flex

It seems that using packages is not working th your custom xml based componts. I have a directory called gridshore, within this folder I have two components:
- Simple.as
- SimpleXml.mxml

Then I have the following declaration in my Application element:
xmlns:gr="gridshore.*"

When using autocomplete I can find the Simple object, but not the SimpleXml. When I do write them and compile them using ant, everthing works. Does someone have more success? I hate these red markers when I know things are oke.

thanks
Jettro

2 comments
Comment actions Permalink

Could you, please, tell us if the directory under source roots of the
module or under content roots?

Jettro Coenradie wrote:

It seems that using packages is not working th your custom xml based componts. I have a directory called gridshore, within this folder I have two components:
- Simple.as
- SimpleXml.mxml

Then I have the following declaration in my Application element:
xmlns:gr="gridshore.*"

When using autocomplete I can find the Simple object, but not the SimpleXml. When I do write them and compile them using ant, everthing works. Does someone have more success? I hate these red markers when I know things are oke.

thanks
Jettro



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

I am using maven for the build, under the src/main folder I have a folder I have a folder flex

You can find the sources online as well:
http://code.google.com/p/gridshore/source/browse/

Have a look at the project books-overview

thanks

ps sorry for the late response, I forgot about it.

0

Please sign in to leave a comment.