Maven2 problems in 7.0.1, modules are invalid

Project that worked in 7.0 does not work anymore all modules are invalid. I replaced 7.0.1 with 7.0 then it start worked again. Can I see what is failing when the modules become invalid? Is this a known 7.0.1 bug?

I have a multi-project pom as parent and two module (child) poms.

A
|--AA
|--AB


A A pom 1 AA AB ]]>

-



And the two child poms are empty (except for the group and artifact id and parent).

5 comments

I am not sure if I can help. But I am also using 7.0.1 and all my Maven modules are invalid as well. Every time I open a Maven project I have to reconfigure JPA facets, switch off JSP validation and re-attach datasources. At this moment Maven 2 integration seems to be useless.

0

Could you please attach you poms? Are you project validated with maven?

0

As for JPA - it doesn't currently supported by maven integration. Could you please create jira request for it? We'll add support as soon as possible.

Why do you need to disable jsp validation anyway?

0

I figured out the problem (at last)! It was my own plugin that was the cause of this. I am developing a SourceGear Vault plugin... I found this out when I noticed maven was working fine with projects that had no connection with the source control.

The main source of the problem was that for windows system I put the env USERPROFILE variable into user.home property because java lookup the user.home by go one step above desktop folder and I have my desktop folder outside my profile. And I needed to have Vault API point to user profile dir, now this bug is fixed by the API instead so my fix is not needed anymore (I think)...

It would be good to get some error message when the a maven pom is reported invalid so you now where to start looking. In this case it said "invalid" as it was something wrong with the pom.

0

Yes, you are right, and we are up to add good error reporting soon.

Thanks for you feedback!

0

Please sign in to leave a comment.