Ruby 0.5 plugin vs Selena/Intellij7

hi, I apologize if this is elsewhere but I am a newbie. I want to use ruby rails! So I have bought a license, seeing the info that I'll be getting 7 also. I thought 7 had ruby/rails but I found out that only selena has it. So I now have three large versions of intellij on my mac and no ruby/rails plugin. I did download the Ruby_4352.jar and I tried putting it into the appSupport directory, to no avail. Here are my questions;

[]how do I uninstall the 2 extra versions?

[]how do I get the latest ruby plugin to be seen and useable? Currently when I open up Selena-7274.app with the latest jar in my app support, it says "installed ruby incompatible". And when I remove it from that directory it says nothing for ruby under installed -nor- under available.

I see all these versions are very new so maybe there's a little tweak you all need to add. I am glad I found the first words on the demo page telling me to get the plugin :)
http://www.jetbrains.com/idea/training/demos/ruby.html

2 comments
Comment actions Permalink

Ruby plugin always compatible only with the latest EAP (which is
frustrating, especially when plugin developers can't make an update for
some time). Download it from
http://www.jetbrains.net/confluence/display/IDEADEV/Selena+EAP . Go to
Settings->Plugins, switch to Available tab and find Ruby plugin.
Right-click on it, Download and Install, restart IDEA.

-serg

ps. it's also better to try software first, because I wouldn't say that
Ruby support in IDEA is the best at the moment.

Anne Moroney wrote:

hi, I apologize if this is elsewhere but I am a newbie. I want to use ruby rails! So I have bought a license, seeing the info that I'll be getting 7 also. I thought 7 had ruby/rails but I found out that only selena has it. So I now have three large versions of intellij on my mac and no ruby/rails plugin. I did download the Ruby_4352.jar and I tried putting it into the appSupport directory, to no avail. Here are my questions;

[]how do I uninstall the 2 extra versions?

[]how do I get the latest ruby plugin to be seen and useable? Currently when I open up Selena-7274.app with the latest jar in my app support, it says "installed ruby incompatible". And when I remove it from that directory it says nothing for ruby under installed -nor- under available.

I see all these versions are very new so maybe there's a little tweak you all need to add. I am glad I found the first words on the demo page telling me to get the plugin :)
http://www.jetbrains.com/idea/training/demos/ruby.html

0
Comment actions Permalink

Hi, Anne!

>[]how do I get the latest ruby plugin to be seen and useable?
At the current moment the latest Ruby Plugin(Ruby_4352.jar) isn't compatible with Selena-7274. But you may download the previous Selena EAP(http://download.jetbrains.com/idea/idea7269.dmg).

Then
>Go to Settings->Plugins, switch to Available tab and find Ruby plugin.
>Right-click on it, Download and Install, restart IDEA

Also the latest plugin version is 0.2 (not 0.5), for more information visit http://www.jetbrains.net/confluence/display/RUBYDEV/Rubyplugin0.2releasenotes.

>[]how do I uninstall the 2 extra versions?
You can delete corresponding idea's *.app from Applications folder. If you want to use Selena and copletely remove IDEA 6 you should also delete your Idea 6 settings and caches:
Config: ~/Library/Preferences/IntelliJIDEA60
System: ~/Library/Caches/IntelliJIDEA60
Plugins: ~/Library/Application Support/IntelliJIDEA60

0

Please sign in to leave a comment.