Flex 2 .mxml / ActionScript 3.0 support (plugin)?

Hi,

It's too annoying to work in eclipse (flex builder) after IDEA... Is there any thoughts on support flex 2 in IDEA?

It looks like idea has everything in place to support code completion for mxml, as well as support for actionscript 3.0 as it's so close to java and idea has implemented javascript highliting and code completion after all.

any thoughts? guesses?

6 comments

If such a plugin existed that would be great.

(this is not a very helpful reply, but maybe the number of replies makes IntelliJ realize this would be a nice product (flexbuilder costs about 500 EUR, so it doesn't have to be free (although that would be even better ;))

0

Definitely! We're looking at moving to flex, which esentially means away from Idea and into eclipse. That will suck. Please Intellij, Please. Keep helping make my life not suck and make a flex 2 plugin for Idea.

0

And yes, we would definitely pay for it

0

Please we really love IntelliJ Idea, and would love to not have to switch to Eclipse/FDT to work on Actionscript/Flex projects.

0

Same thing for us...we have been using Intellij since it came out. Now that we are moving to Rails and Flex2, we pretty much are stuck with Eclipse (RadRails and Flex2 Builder).

Please provide a plugin for Flex2!

0

http://www.jetbrains.net/jira/browse/IDEADEV-14365

wessel wrote:

If such a plugin existed that would be great.

(this is not a very helpful reply, but maybe the number of replies makes IntelliJ realize this would be a nice product (flexbuilder costs about 500 EUR, so it doesn't have to be free (although that would be even better ;))



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.