problems running a Web App using JBoss

In Intellij 5.1, after creating a project containing a single module (a web app) using the JBoss plugin, and creating a configuration using the default instance of my JBoss 4.0.5.GA server, I am trying to run the application but it doesn't work.
I get a long list of
'--- packages waiting for a deployer ---'
all of the form:
org.jboss.deployment.DeploymentInfo@2f4b6c45 { url=file:/D:/Program Files/jboss-4.0.5.GA/server/default/deploy/conf/DBStateImpl.xml }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/D:/Program Files/jboss-4.0.5.GA/server/default/deploy/conf/DBStateImpl.xml
altDD: null
lastDeployed: 1166620478565
lastModified: 1166620478534
mbeans:

What does that mean? and what should I do?

Thanks,
Cois

5 comments
Comment actions Permalink

Are you trying to deploy a WAR file or an exploded directory?

0
Comment actions Permalink

I know the previous person hasn't answered your question (Martin) yet but I have the exact same problem and it only happens when I use the exploded war. The regular war deploys fine.
I am using intellij 6.0 and jboss 4.05
I have searched the web for a solution to this and can't find anything.

Any help would be appreciated
Ed

0
Comment actions Permalink

Hello Ed,

JBoss chooses the appropriate deployer internally based on the file extension of the deployment source. In order to give JBoss the possibility to choose the web deployer to deploy your exploded directory, you have to add a .war extension to the directory, e.g. 'exploded.war'. This should solve your problem.

(I just committed a modification of the plugin today which will show a prominent warning message in this situation.)

- Martin

0
Comment actions Permalink

Yep!. That was it.
Thanks for your help.
Ed

0
Comment actions Permalink

Yes. Thanks a lot.
This solved my problem as well.

François

0

Please sign in to leave a comment.