JBoss Integration configuration issue with non-default startup script cmd

I am trying to get JBoss running from inside the Idea IDE, but I can't seem to get a necessary parameter added to the startup command. When we start it using the command line, we use this command:
run -c isd -b <ip address>
and it works. But I can't figure out how to set this up in the JBoss Integration's Run Configuration.

On the Startup/Connection tab, there is a "Startup script:" value that is by default set to 'use default'. When I change this and try to add the -b <ip address> to what was there by default, I get the following error mesage when I try to start JBoss:

run.bat: option requires an argument -- c

The command it is running (shown at the top of the message pane) is:

cmd /c "C:\u1\opt\jboss-4.0.4.GA\bin\run.bat -b 127.0.0.1 -c isd" -c

When I have it set to use the default, the command is:

cmd /c C:\u1\opt\jboss-4.0.4.GA\bin\run.bat -c isd

I have tried not including the -c isd and changing the order of the options, but nothing had made any difference.

I am currently using IDEA v5.1 (#4155) and the latest version of JBoss Integration v2.13. I had been using an older version of the plugin and was getting the same results as with the latest version.

Does anyone have any suggestions or ideas as to what I am doing wrong? Could this be a bug in the JBoss Integration plugin? Or am I trying to use the 'Startup script:' field in a manner not intended?

Thanks,
saF

1 comment

I have currently no IDEA 5 at hand to test, but maybe this one could help you:
http://www.intellij.net/forums/thread.jspa?messageID=5172005#5172005

0

Please sign in to leave a comment.