fileTypeFactory isn't getting invoked

I am working on a custom language plugin and in intellij 13.1, the fileTypeFactory extension point isn't getting called.

For the purposes of troubleshooting the error, I have created this very simple plugin:

https://github.com/georgewfraser/hellolang

It is just a file type ".hello" and an icon.

I've added `throw new RuntimeException("Loaded .hello");` in HelloFileTypeFactory to verify whether the plugin is getting loaded.

When I run the plugin run configuration from IntelliJ, it correctly throws the error.

When I do 'Build -> Prepare Plugin Module 'hello' for deployment' and install the resulting 'hello.jar' as a plugin, the error does not get thrown when I restart IntelliJ. The plugin shows up as installed, but the '.hello' file type is not listed under 'Settings -> File types'

Why is `HelloFileTypeFactory.createFileTypes` never getting called?

2 comments
Comment actions Permalink

It works for me, Please double-check you installed it into the installation you're trying to run it with.

If it still does not work:
What build number of IJ are you using? Did you verify META-INF/plugin.xml is in hello.jar?

0
Comment actions Permalink

Running 135.909

I was using a pre-release build of Oracle Java 8. Updating to the latest Java fixed it.

0

Please sign in to leave a comment.