[ANN] JFormDesigner Plug-in Early Access 10

Hello,

a new Early Access release of the JFormDesigner plug-in
for IntelliJ IDEA 5.0 and later (5.1, 6.0 beta) is
available now.

New features in EA10:

  • I18n: Two-way synchronization of localized strings in designer and in properties file editors.

  • "Delete Locale" command added.

  • TableModel property editor now supports java.util.Date as column type.


New features in EA9:

  • Convert IntelliJ IDEA or Netbeans .form files to JFormDesigner forms. Select .form file(s) in the Project view and select "Convert to JFormDesigner Form..." from the popup menu to convert forms.

  • Column/row headers: Resizing of columns/rows to change (minimum) size.

  • Enhanced TableModel editor: Specification of column widths, resizable flag and predefined values for combo box editor.


New features in EA8:

  • Java code generator: Renames existing event handler methods when changing the event handler name.

  • Java code generator: Renames existing component getter methods and update the return statement when renaming a component.

  • Java code generator: Renames existing nested classes when changing the "Nested Class Name" property.

  • Java code generator: Updates the extends clause of a class when a morphing bean, which is connected to a (nested) class.


New features in EA7:

  • I18n: Updating properties files without loosing comments and order of keys.

  • I18n: Template for new properties files.

  • I18n: Reload properties files on external changes.

  • Localization of javax.swing.Action properties.

  • GridBagLayout: New option to use empty GridBagConstraints constructors (for Java <= 1.1).

  • null layout manager: move selected components with CtrlArrowKey and change size with ShiftArrowKey. New commands "Make Horizontal/Vertical Space Equal" added to popup menu. All alignment commands have now keyboard shortcuts.

  • Java code generator: Determine source compatibility of generated code from project. E.g. if project language level is Java 5, then JFormDesigner generates Java 5 compatible source code. You can change the source compatibility level in the settings.

  • Java code generator: Parametrization of component class names (e.g. MyComponent<String>).

  • Java code generator: Option to use 'this' to access component member variables.

  • Java code generator: Specification of i18n getString() format.

  • Updated JGoodies Looks to 2.0.4.


Fixed bugs in EA10:

  • Fixed: Using TitledBorder may cause errors on save when IntelliJ IDEA runs on Java 6.

  • Fixed exception when removing last column/row in GridBagLayout or TableLayout.

  • jfd-loader.jar: Event handler methods not added to windows (JFrame, JDialog, etc) when specifying an owner.

  • Minor bugs fixed.


Fixed bugs in EA8:

  • Fixed: Using JTabbedPane, JScrollPane, JSplitPane, etc. as superclass for new forms works now as expected.


Fixed bugs in EA7:

  • Fixed BeanInfo problem in case that IntelliJ IDEA's GUI builder is used parallel to JFormDesigner (JFormDesigner got dt.jar BeanInfos).

  • Java code generator: Fixed generation of uncompilable code when using null layout manager in JFrame.

  • Java parser now allows curly brackets outside of class (e.g. for annotations).



See: http://www.jformdesigner.com/idea/
Use the IntelliJ IDEA Plug-in Manager to download and install it.

--
Karl Tauber
FormDev Software
http://www.jformdesigner.com/

4 comments
Comment actions Permalink

Karl Tauber wrote:

Use the IntelliJ IDEA Plug-in Manager to download and install it.


Did not work for me, installed it manually....

Johannes Schneider

0
Comment actions Permalink

Hi Karl,

It seems that the update is not recognized by the plugin-manager.

Kind regards

Thomas Gülden
Munich, Germany

0
Comment actions Permalink

Hi Thomas and Johannes,

seems that IDEA does not recognize that ea10 is greater than ea9...

Fixed the problem in EA 11.

--
Karl Tauber
FormDev Software
http://www.jformdesigner.com/

0
Comment actions Permalink

Karl,

It seems that IDEA does a simple String.compareTo on the non-numeric parts of the version number. I suffered from the same problem already. You'll better start with ea01 next time... :) I even used 1.0.-ea01 to be able to use 1.0.0 at the end.

- Martin

Hi Thomas and Johannes,

seems that IDEA does not recognize that ea10 is
greater than ea9...

Fixed the problem in EA 11.

--
Karl Tauber
FormDev Software
http://www.jformdesigner.com/

0

Please sign in to leave a comment.