SQL plug-in not working

I have been trying to use the SQL plug-in to no avail.

It connects to the database but doesn't seem to use the instance
parameter, and doesn't show database contents as expected.

Please help.

Thanks,
Amnon

2 comments
Comment actions Permalink

Hi Amnon,

The instance is passed as parameter to the connection. It doesn't appear
in the connection URL because I use a properties map instead.

Do you get any error messages?
Did you make the JDBC driver library
known to the plugin? Either by placing it in the ]]>\config\plugins\ks-sql\libs directory of your installation or
added it to JDBC Drivers on the 'Miscellanous' tab in the plugin
settings dialog.

You can also try to use 'Other Driver' as driver and setup your JDBC URL
manually.



Stefan.

Amnon I. Govrin wrote:

I have been trying to use the SQL plug-in to no avail.

It connects to the database but doesn't seem to use the instance
parameter, and doesn't show database contents as expected.

Please help.

Thanks,
Amnon

0
Comment actions Permalink

Hi Stefan,

Answers below.

May be I am just using it wrong.

Is it tested with SQL Express 2005?

I must be doing something wrong here...

Thanks,
Amnon

Stefan Stiller wrote:

Hi Amnon,

The instance is passed as parameter to the connection. It doesn't appear
in the connection URL because I use a properties map instead.

Thanks for the explanation.


Do you get any error messages?

No. It all looks like it's working but I can't run a simple query or
look at the tables.

Did you make the JDBC driver library
known to the plugin? Either by placing it in the <IntelliJ User
Directory>\config\plugins\ks-sql\libs directory of your installation or
added it to JDBC Drivers on the 'Miscellanous' tab in the plugin
settings dialog.

Yes, using JTDS 1.2 (same as what we use in our project).


You can also try to use 'Other Driver' as driver and setup your JDBC URL
manually.



Stefan.

Amnon I. Govrin wrote:

>> I have been trying to use the SQL plug-in to no avail.
>>
>> It connects to the database but doesn't seem to use the instance
>> parameter, and doesn't show database contents as expected.
>>
>> Please help.
>>
>> Thanks,
>> Amnon

0

Please sign in to leave a comment.