Webservice plugin not finding localhost server.

Hello,

I just downloaded and installed the webservice plugin (version 0.5 build 2) for intellij
(5.1.1 build 4192). My problem is that I can not get the plugin to recognize that an instance of tomcat is running. The steps I took were:

1. I created a WebApp Module.
2 I run the WebService Enable support option from the Tools menu. The result of this action seems to correctly add the axis jar files to the project.
3. I configure and run an instance of Tomcat locally(inside intellij of course). As a result of doing this I can see the /services page with the two default axis web services... (I run this instance on the default context and port ==> localhost:8080/services)
4. I select the java class that will become the service and from the tools menu I choose "Deploy Java Class as web service". this action prompts me to enter all the relevant information but the status on that dialog box says: The webserver localhost:8080 is not running...

I tried to change the ports and the context of the web app but it seems to not find the tomcat instance that is running, any ideas?

Thanks!

M.

1 comment
Comment actions Permalink

Hi,

There is known problem about webservices plugin does not work correctly when tomcat does not have 'ROOT' webapplication (TomCat has it by default). Thus using fresh TomCat copy should help.

0

Please sign in to leave a comment.