Current 13 EAP (132.325) doesn't compile with Ant

Hi all,

I'm trying to compile the sources for the current EAP using Ant, and it's not working (error below). I normally compile in order to get the file to add to my SDK. Is there something I need to do to fix this? If I change the SDK in my project the SDK changes in the error message, but I don't know why it can't find it. The project compiles fine inside IntelliJ.


     [java] compile:
     [java] jdkHome is not defined. Defaulting to /Library/Java/JavaVirtualMachines/1.6.0_29-b11-402.jdk/Contents/Home
     [java] Loaded project /Users/colin/dev/community: 160 modules, 53 libraries
     [java] ##teamcity[progressMessage 'Cleaning up sandbox folder']
     [java]    [delete] Deleting directory /Users/colin/dev/community/out
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/dist.all.ce
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/dist.unix.ce
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/dist.mac.ce
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/artifacts
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/artifacts/core
     [java]     [mkdir] Created dir: /Users/colin/dev/community/out/artifacts/jps
     [java] Starting build; cache directory: /Users/colin/dev/community/.jps-build-data
     [java] ##teamcity[blockOpened name='Resources for |'xslt-rt|' production']
     [java] ##teamcity[blockClosed name='Resources for |'xslt-rt|' production']
     [java] ##teamcity[blockOpened name='Module |'xslt-rt|' production']
     [java] ##teamcity[compilationStarted compiler='java']
     [java] ##teamcity[message text='Cannot find JDK |'IDEA JDK|' for module |'xslt-rt|'' status='ERROR']
     [java] ##teamcity[compilationFinished compiler='java']
     [java] ##teamcity[compilationStarted compiler='java']
     [java] ##teamcity[message text='Compilation failed' status='ERROR']
     [java] ##teamcity[compilationFinished compiler='java']
     [java] ##teamcity[blockClosed name='Module |'xslt-rt|' production']
     [java] ##teamcity[compilationStarted compiler='']
     [java] ##teamcity[message text='Compilation failed' status='ERROR']
     [java] ##teamcity[compilationFinished compiler='']
     [java] BUILD FAILED
     [java] /Users/colin/dev/community/build/gant.xml:40: Compilation failed
     [java] Total time: 2 seconds

Comment actions Permalink

Same here, with 134.SNAPSHOT ?:|

The main instructions page (as well as README in the project) suggest to use ant to build an artifact.

Building and Running from the Command Line

To build the distribution archive of IntelliJ IDEA Community Edition, execute build.xml Ant build script in the root directory of the source code. The results of the build execution can be found at out/artifacts.

I found another recommendation on building an artifact:

Ant way to compile is deprecated in our project.
In case if you need to compile production binaries, please use from IDEA: Build -> Build Artifacts -> Production

But there are no such targets in build and the project properties does not define any artifacts :O

I tried to run another command in IDEA: Build > IntelliJ IDEA CE build file > "<default target>"

Comment actions Permalink

Well, I was able to build 134.SNAPHOT with some voodoo ]:)

Since it was not building with master, I did checkout 133, and was able to build artifacts. Then, feeling bold and adventurous, I checked-out master again and this time it worked. Git was clean, no changes whatsoever. Magic.

Yet, there's still no trace of Build > Build Artifacts > Production


Please sign in to leave a comment.