TestNG plugin cannot run in Demetra build 5201

In previous builds of Demetra, TestNG plugin can run but has error. But now it cannot run in build 5201. :(

When I run it, I got this exception

(TestNGResults.java:96)
	at com.theoryinpractice.testng.TestNGConsoleView.buildView(TestNGConsoleView.java:88)
	at com.theoryinpractice.testng.TestNGConsoleView.(TestNGConsoleView.java:36)
	at com.theoryinpractice.testng.TestNGRunnableState.execute(TestNGRunnableState.java:78)
	at com.intellij.execution.runners.RunStrategy.executeCommandLine(RunStrategy.java:59)
	at com.intellij.execution.runners.RunStrategy.a(RunStrategy.java:21)
	at com.intellij.execution.runners.RunStrategy.access$000(RunStrategy.java:7)
	at com.intellij.execution.runners.RunStrategy$3.run(RunStrategy.java:11)
	at com.intellij.execution.impl.ExecutionManagerImpl$1.run(ExecutionManagerImpl.java:1)
	at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.run(LaterInvocator.java:4)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:5)
	at com.intellij.ide.IdeEventQueue.a(IdeEventQueue.java:76)
	at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:132)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
]]>

1 comment

t800t8 wrote on 26/03/06 14:00:

In previous builds of Demetra, TestNG plugin can run but has error. But now it cannot run in build 5201. :(


Yep - I know about this - sadly, I'm reusing part of the JUnit plugin
for the ModuleBasedRunner configuration and in the current EAP builds
JetBrains have broken the JUnit plugin in such a way that it can't be
compiled :(

I was hoping to take a look at this weekend and look at removing the
JUnit dependency if possible but I'm not going to get to it as I'm
heading to my parents place (dads heading into surgery on Monday).

I've not yet entered a "bug report" for the JUnit plugin as we're
technically using undocumentated APIs so its our own fault :(

0

Please sign in to leave a comment.