Using PasswordStorage from a plugin

Hi,

My plugin requires that user defines some passwords and I want to store them in the secure storage. I managed to do it using PasswordStorage API but I just discovered that this class is not part of Open API but come from idea.jar.

Is it safe to use it or is there a possibility that interface PasswordStorage will be modified in a non backward compatible way in future releases of IntelliJ?

Thanks

Julien

2 comments

The possibility that a class will be modified in a non-backward-compatible way exists for any class in IntelliJ IDEA, regardless of whether it's part of the OpenAPI or not.

0

OK, so I understand it is fine to use PasswordStorage.

Thanks

0

Please sign in to leave a comment.