CVS issue in 5.0.2 - compare versions not working

Hi I have encountered following error on two computers, two projects stored in different CVS repositories.

After setting up the CVS repository everything worked fine, but some time later I am unable to compare versions of source files.

I go to CVS history - see everything fine, but when i try to compare two different versions of the file I get the message: Cannot show differences, revision 1.11 does not exist in repository.

CVS output window shows:
<![CDATA[. cvs checkout -l -p -r 1.11 ./project/my/package/path/ recurse.c:639: failed assertion `strstr ( repository, "/./" ) == NULL' [checkout aborted]: received abort signal Command finished ( 1 ) ]]>
The same happens when I try to compare current file with latest repository version, etc.

Funny thing that comparing works on different computer, using project files copied earlier from the 'currently broken' one.
The CVS output differs
<![CDATA[. cvs checkout -l -p -r 1.11 project/my/package/path/ ]]>
I assume that it fails because of the './' part but have no IDEA why one of the computers uses './' and how to get rid of it.

Comment actions Permalink

here is the stacktrace, but the source of error is passing incorrect path to CVS:
<![CDATA[ Assertion failed: state = 2 java.lang.Throwable at com.intellij.openapi.diagnostic.Logger.assertTrue( at com.intellij.cvsSupport2.cvsoperations.cvsContent.GetFileContentOperation.loadFileBytes( at com.intellij.cvsSupport2.cvsoperations.cvsContent.GetFileContentOperation.getFileBytes( at com.intellij.cvsSupport2.cvsoperations.cvsContent.GetFileContentOperation.fileNotFound( at com.intellij.cvsSupport2.history.ComparableVcsRevisionOnOperation.fileNotFound( at com.intellij.cvsSupport2.history.CvsFileContent.fileNotFound( at com.intellij.cvsSupport2.history.CvsFileContent.loadContent( at com.intellij.openapi.vcs.history.FileHistoryPanelImpl$TreeNodeOnVcsRevision.loadContent( at com.intellij.openapi.vcs.history.FileHistoryPanelImpl.a( at com.intellij.openapi.vcs.history.FileHistoryPanelImpl.access$800( at com.intellij.openapi.vcs.history.FileHistoryPanelImpl$MyDiffAction.actionPerformed( at com.intellij.openapi.vcs.history.FileHistoryPanelImpl$AbstractActionForSomeSelection.actionPerformed( at com.intellij.openapi.actionSystem.impl.ActionButton.performAction( at com.intellij.openapi.actionSystem.impl.ActionButton.processMouseEvent( at java.awt.Component.processEvent( at java.awt.Container.processEvent( at java.awt.Component.dispatchEventImpl( at java.awt.Container.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.LightweightDispatcher.retargetMouseEvent( at java.awt.LightweightDispatcher.processMouseEvent( at java.awt.LightweightDispatcher.dispatchEvent( at java.awt.Container.dispatchEventImpl( at java.awt.Window.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.EventQueue.dispatchEvent( at com.intellij.ide.IdeEventQueue.defaultDispatchEvent( at com.intellij.ide.IdeEventQueue.a( at com.intellij.ide.IdeEventQueue.dispatchEvent( at java.awt.EventDispatchThread.pumpOneEventForHierarchy( at java.awt.EventDispatchThread.pumpEventsForHierarchy( at java.awt.EventDispatchThread.pumpEvents( at java.awt.EventDispatchThread.pumpEvents( at ]]>

Comment actions Permalink

CVS output window shows:
. cvs checkout -l -p -r 1.11 ./project/my/package/path/
recurse.c:639: failed assertion `strstr ( repository, "/./" ) == NULL'
: received abort signal

What exact version is your CVS server?


Comment actions Permalink

1. CVS 1.12.12 behind cvsd 1.0.7
2. obsolete 1.11 something

I created my project on computer A using server 1.
I copied the project files to computer B, to also use server 1. Later the problems started on computer A, on B there are no problems.

Computer B is also using server 2 for different project, and today error in this environment occured, so I thought it is rather IDEA issue and reported it.

Comment actions Permalink

Could you please attach CVS/Repository file from the directory project/my/package/path?

Comment actions Permalink

It happens to all files in those projects, for example web.xml file.
I have generated CVS history, then tried to compare two last releases - 1.7
and 1.6

CVS output
<![CDATA[c:\idea5\bin cvs log ./listy/scripts/templates/web.xml RCS file: /home/cvvs/projekt/./listy/scripts/templates/web.xml,v Working file: ./listy/scripts/templates/web.xml head: 1.7 branch: locks: strict access list: symbolic names: dupa: 1.2 start: Adam: 1.1.1 keyword substitution: kv total revisions: 8; selected revisions: 8 description: ---------------------------- revision 1.7 date: 2006/01/16 00:58:43; author: adam; state: Exp; lines: +11 -6 archiveEdit works! ---------------------------- revision 1.6 date: 2006/01/12 01:09:10; author: adam; state: Exp; lines: +1 -1 improved production code layout ---------------------------- revision 1.5 date: 2006/01/11 13:01:02; author: adam; state: Exp; lines: +1 -1 fixed OSIV problem ---------------------------- revision 1.4 date: 2006/01/11 12:34:34; author: adam; state: Exp; lines: +1 -5 investigating OSIV problem ---------------------------- revision 1.3 date: 2006/01/11 01:31:00; author: adam; state: Exp; lines: +37 -8 hibernate lazy init problems ---------------------------- revision 1.2 date: 2006/01/03 01:23:51; author: adam; state: Exp; lines: +24 -19 completed mappings ---------------------------- revision 1.1 date: 2005/12/31 16:28:38; author: adam; state: Exp; branches: 1.1.1; Initial revision ---------------------------- revision date: 2005/12/31 16:28:38; author: adam; state: Exp; lines: +0 -0 initial import of listy application ============================================================================= Command finished ( 0 ) . cvs checkout -l -p -r 1.7 ./listy/scripts/templates/web.xml cvs: recurse.c:668: do_recursion: Assertion `strstr (repository, "/./") == ((void *)0)' failed. cvs [checkout aborted]: received abort signal Command finished ( 0 ) ]]>
and the contents of file
c:\projects\listy\scripts\templates\CVS\Repository are
<![CDATA[./listy/scripts/templates ]]>
All CVS/Repository files in this project begin with ./listy

I have just checked another project, where diffs do work - and the content of
these files is just the project name, without './'

Comment actions Permalink

Yet another question.
Was the project checked out using IDEA?
If it was please try to check it out (meybe not the whole project but some directory) with cvs logging(CVS->Global Settings->log cvs client/server output) enabled and attach the result.

Comment actions Permalink

Hi, this was a good question, I remeber something.

I think the projects in the environments that got broken were created from scratch and then "Imported into CVS" by IDEA.

The systems that do work - I have used IDEA to check out the code.

That might be the reason I have not noticed it earlier - I was working on machines different then the ones that created the project, also you do not create new CVS projects too often.


Please sign in to leave a comment.