CompileWithoutDependencies plugin is broken

Please could somebody from Jetbrains remove the
CompileWithoutDependencies plugin from the repository? It just throws
NoClassDefFoundErrors on a current version of IDEA:

http://www.intellij.net/tracker/idea/viewSCR?publicId=58881
http://www.intellij.net/tracker/idea/viewSCR?publicId=56895

But because its vendor is "IntelliJ" users could think it is properly
functioning and supported plugin.

Bas

4 comments

Hello Bas,

Please could somebody from Jetbrains remove the
CompileWithoutDependencies plugin from the repository? It just throws
NoClassDefFoundErrors on a current version of IDEA:

http://www.intellij.net/tracker/idea/viewSCR?publicId=58881
http://www.intellij.net/tracker/idea/viewSCR?publicId=56895

But because its vendor is "IntelliJ" users could think it is properly
functioning and supported plugin.


This plugin is for 4.5 IDEA version, IDEA 5.1 has a checkbox controlling
compiler behavior in Settings | Compiler.
Build number information clearly states that this plugin will not work with
any build higher than 2253.

There are still IDEA 4.5 users who may need this plugin.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Hi Serge,

Serge Baranov wrote:

Hello Bas,

>> Please could somebody from Jetbrains remove the
>> CompileWithoutDependencies plugin from the repository? It just throws
>> NoClassDefFoundErrors on a current version of IDEA:
>>
>> http://www.intellij.net/tracker/idea/viewSCR?publicId=58881
>> http://www.intellij.net/tracker/idea/viewSCR?publicId=56895
>>
>> But because its vendor is "IntelliJ" users could think it is properly
>> functioning and supported plugin.
>>


This plugin is for 4.5 IDEA version, IDEA 5.1 has a checkbox controlling
compiler behavior in Settings | Compiler.


Judging by the exception reports, many users do not know that.

Build number information clearly states that this plugin will not work with
any build higher than 2253.


Yes, on display in the bottom of a locked filing cabinet stuck in a
disused lavatory with a sign on the door saying Beware of the Leopard:-)
This cannot be seen from inside IDEA, as far as I know.

There are still IDEA 4.5 users who may need this plugin.


Well I guess that's true, but they should have this plugin already. Why
does IDEA 5.0 show this plugin in the plugin manager anyway?

Bas

0

Hello Bas,

>> There are still IDEA 4.5 users who may need this plugin.
>>

Well I guess that's true, but they should have this plugin already.
Why does IDEA 5.0 show this plugin in the plugin manager anyway?


That is the right question =). Plugin manager should be rewritten and must
not show plugins that do not match build interval.

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Bas Leijdekkers wrote:
>> There are still IDEA 4.5 users who may need this plugin.


Well I guess that's true, but they should have this plugin already. Why
does IDEA 5.0 show this plugin in the plugin manager anyway?


Because not all of its versions have the "until-build" set. The one you see in
the Plugin Manager is version 1.0:
http://plugins.intellij.net/plugins/view/?id=CompileWithoutDependencies

Another requirement for the new plugins page: It should be possible to change
the "until build" once a certain version appears to be incompatible with newer
builds.

Sascha

0

Please sign in to leave a comment.