JBoss Plugin tutorial

Hi

Im very new to webapp/jsps/etc so this might be obvious i just cant figure out what it is

Im using intellij 5.0.1, JBoss 4.0.1sp1, and JBoss plugin 2.2

After following the plugin tutorial for every step (twice) i just needed to ask on here (the one with the hello world and getDate)

I keep getting the error message

type Status report

message /sample/greeting

description The requested resource (/sample/greeting) is not available.

I dont know what im doing wrong...

I tried reloading the browser, closing the browser and rerunning and its the same error

Any ideas?
Thanks Dave

1 comment
Comment actions Permalink

The problem is that your application module isn't deployed. In earlier versions of IDEA the application module was automatically selected for deployment when creating a new run configuration. In IDEA 5.0 this doesn't seem to be the case anymore (and the tutorial hasn't been updated yet).

Here are the steps to fix the problem:

- edit the run configuration;
- go to tab 'Deployment';
- select the application module;
- check the box 'Deploy J2EE Application Module'.

After fixing this the application module is deployed automatically after the server has finished starting up.

0

Please sign in to leave a comment.