Perforce with IDEA 5.0 and 5.0.1 on XP

Hello,
I have been unable to get IDEA to work properly with Perforce version control. I really want to use IDEA for my Java software development, but it has been days now without version control and unless I can get it to work soon, I will need to try a different IDE (which I'd really rather not do because I think IDEA is great). So I hope very much that one of you out there can tell me what is necessary to use Perforce with IDEA! Thank you in advance. Here's the deal:

THE PROBLEM: All files appear as "brown" in the project hierarchy within IDEA. If I choose "Edit" from the Perforce menu in IDEA, I get an error like this:

"File not on server: C:/code/perspectors/GeometricNarrator/src/cife/fslp/Color.java"

1. The project source files are already in Perforce.

2. I have tried both the standard 5.0 build, as well as the latest build (#3459, 18 August 2005).

3. Perforce is running on the same machine as IDEA.

4. My Perforce client spec / workspace is called "thinkgn".

5. The actual location in the Perforce depot for (by example) the file mention in the error message above, looks like this: //depot/gn/main/src/cife/fslp/Color.java

6. In the "Version Control Configurations" page, I have tried:
a) manually specifing client name, user, port
b) checking the "Use P4CONFIG or default connection" setting, and creating a text file in the project root with the client/user/port settings, and setting the P4CONFIG variable using the "p4 set P4CONFIG=" command.

7. I have also set the P4CLIENT variable, using the "p4 set P4CLIENT=thinkgn" command.

8. I have enabled output logging for Perforce within IDEA and the p4.output file contains the following (a few excerpts of the file):

infoErrCode=0
StdOut:----


User name: bsuter
Client name: thinkgn
Client host: think
Client root: c:\code\perspectors\GeometricNarrator
Current directory: c:\Program Files\JetBrains\IntelliJ IDEA 5.0\bin
Client address: 127.0.0.1:1484
Server address: localhost:1666
Server root: C:\Program Files\Perforce
Server date: 2005/08/18 15:14:56 -0700 Pacific Standard Time
Server version: P4D/NTX86/2005.1/83219 (2005/07/25)
Server license: none

StdErr:----



fstat C:/code/perspectors/GeometricNarrator/src/cife/fslp/Color.javaErrCode=0
StdOut:----



StdErr:----



End----




9. IDEA's bin directory contains an hs_err_pidXXX.log file, and here's a selected excerpt:

j org.jetbrains.idea.perforce.perforce.P4Connection$1.runProcess()V+79
j org.jetbrains.idea.perforce.perforce.PerfExecutionThread$1.run()V+4
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub



I look forward to your help and suggestions. Thank you!

PS: I found a thread about a similar matter, but did not find a solution there. I have tried both 5.0 and 5.0.1 build #3459, both on Windows XP with Java 1.5.

1 comment
Comment actions Permalink

I, too, saw the same problem. It must have been introduced recently since I just upgraded from build 3430 and was using p4 effectively with that build.

Fortunately I found a workaround: I turned off the 'Use native Perforce API' option and the p4 integration started to work.

0

Please sign in to leave a comment.