Testng and mac os x

Hello,

I've installed the latest testng plugin on my mac and when I start up intellij I get the fallowing error:

Original exception: com/theoryinpractice/testng/ TestNGConfigurationType (Unsupported major.minor version 49.0)
java.lang.UnsupportedClassVersionError: com/theoryinpractice/testng/ TestNGConfigurationType (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
...

I asume that this has something to do with the version of java. I have 1.5 installed and verifieid:

zsh-% java -version
java version "1.5.0_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)
Java HotSpot(TM) Client VM (build 1.5.0_02-36, mixed mode, sharing)

JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Home



Is there a way to check that intellij is running on 1.5? Is there some other issue with the pluging that I'm missing? I still have the problem after installing intellij 5.0.1 and pluging version 1.9.

Thanks,
Michael

1 comment
Comment actions Permalink

Yep, edit the Info.plist file in /Applications/IntelliJ\ IDEA\ 5.0.app/Contents/Info.plist

Search for 1.4, and change it to 1.5, and everything should run fine.

I develop the tng plugin on OSX, so it's definitely supported!

0

Please sign in to leave a comment.