Can't run JBoss configuration

I'm trying to run J2ee app from Idea on the remote JBoss server. Until now I've just used ant script to build/deploy app. But now I want to check the Idea's way of doing this. In Run/Debug configuration I'm setting up the host, leaving default values for ports. Deployment method I select is shared filesystem (I have the remote server's folder mapped locally).

But now, when I try to run the configuration, Idea immediately gives me an error pop up: "Error running Myhost JBoss: Unable to connect to the myhost:8080".

The Jboss is there and running fine. Any ideas on what is wrong here? This pop up is thrown before any attempts to compile/deploy - just after I click "run" button. And there is nothing in the log file either.

Idea 5.0.1, Jboss Integration plugin 2.0-eap12

1 comment
Comment actions Permalink

Victor,

This is a known issue which will be corrected in the final version of
JBoss plugin for IDEA 5. Should be available through plugin manager very
soon.

victorstar wrote:

I'm trying to run J2ee app from Idea on the remote JBoss server. Until now I've just used ant script to build/deploy app. But now I want to check the Idea's way of doing this. In Run/Debug configuration I'm setting up the host, leaving default values for ports. Deployment method I select is shared filesystem (I have the remote server's folder mapped locally).

But now, when I try to run the configuration, Idea immediately gives me an error pop up: "Error running Myhost JBoss: Unable to connect to the myhost:8080".

The Jboss is there and running fine. Any ideas on what is wrong here? This pop up is thrown before any attempts to compile/deploy - just after I click "run" button. And there is nothing in the log file either.

Idea 5.0.1, Jboss Integration plugin 2.0-eap12


--
Martin Fuhrer
Fuhrer Engineering AG
http://www.fuhrer.com

0

Please sign in to leave a comment.