[ANN] J2MESupport v 1.2 - beta 1

Hi,

for those interested in J2ME development under IDEA,
please find beta version of J2MEsupport plugin at:
http://prz.wz.cz/j2me/j2mesupport.jar.
I'm sorry, but for some reason I couldn't update plugin's TWiKi page.

The plugin still needs to have ant custom task FileSize somwhere on the path, preferably inside ant.jar (the one that IDEA uses). My reccomentadion is to first install the old version (if you haven't do that yet) as described on the plugin home page: http://www.intellij.org/twiki/bin/view/Main/JtoMESupport, then replace the plugin jar with the new version.
Please be aware that old midlet projetcs may not run correctly with the new version. Since the plugin is not final, no migration of project files is provided yet.

Bug reports will be highly appreciated!

Cheers,

Pavlin

9 comments

Hi! Will it be possible to work with vendor-specific sdks (siemens, nokia) or just with Sun's WTK, It would be great if plugin supported native SDKs, and this seems not to be that difficult.

0

Please search the forums there are previous posts discussing these issues.

I myself have no problem using J2ME with MIDP, KDDI-P and DOJA profiles.

Also, there is a J2ME plugin by Pavlin Zahariev, which as far as I know
can set the JDK for you and helps packaging/running midlets.

Another helpful resource is http://antenna.sf.net

Unfortunately the remote debugging in sun's emulator is not working, but
I can learn to live without it...


-- dimiter

0

Hi, J2MESupport plugin does not support vendor specific SDKs. Last version can switch between different versions of SUNs WTK. Actually, it isn't exactlly trivial to add vendor specific emulators support, although I must admit that this is mostly because of limitations in the implementation. I'd like to add more features to the plugin, but as the time as always is an issue, I'd need some motivation for that. Lets say more requests for a specific feature. It would be nice if someone would be interested to give me a hand with that.

Regards,

Pavlin

0

I would be glad to help - specifically, with support for vendor-specific J2ME implementations. Support for the UEI would really help - 90% of my J2ME efforts are spent in Nokia toolkits.

0

I cannot make it work...
INFO - J2MESupport: Start ant build: e:\intellij-idea-4.5\jre\bin\java -cp .;E:/j2sdk1.4.2_07\jre\lib\rt.jar;E:/j2sdk1.4.2_07\lib\tools.jar;..\lib\ant\lib\ant.jar;..\lib\ant\lib\ant-launcher.jar;..\lib\ant\lib\FileSize.jar org.apache.tools.ant.Main -f K:\Java\J2MeTest\build.xml clean

INFO - J2MESupport: emulator process (java.lang.Win32Process@1e2bf04) started ...

INFO - Buildfile: K:\Java\J2MeTest\build.xml

INFO -

INFO - BUILD FAILED

INFO - K:\Java\J2MeTest\build.xml:26: taskdef class FileSize cannot be found


but the FileSize.jar is at that location

0

Hi Yang Lei,
could you please, post here the version of FileSize.jar you have. It seams to me that your FileSize.jar has old packaging (different than expected by the taskdef in build.xml). It is also possible, that "..\lib\ant\lib\FileSize.jar" doesn't point to the place where the task jar resides.

Regards,

Pavlin

0

Hi,
I have been trying all afternoon to debug a jar that i have built with a custom ant script in the IDE. but no matter what emulator I use it returns telling that “failed to establish a connection to the target vm at 127.0.0.1:2027 using socket transport"

Does anyone have any ideas as to why this is or a way to fix it?

regards,
Conor

0

I have been trying for about 4 hours now to get this plug-in to work. But still I get:

taskdef A class needed by class FileSize cannot be found: FileSize (wrong name: org/apache/tools/ant/taskdefs/FileSize)

So, what versions do I have?
Contrary to the instructions on the wiki, I could not find FileSize.jar anywhere. The site says you need it, but the FileSize.jar is not on the site. I only see FileSize.zip on the website. So, I downloaded that and hand wrote a manifest file and made a JAR from the FileSize.class file that was in the ZIP. The strange thing is that the FileSize.class file inside of the ZIP has a 2002 datestamp, though you posted it in 2004. Maybe that is not the right version?

I put the JAR I made in many locations, including lib\ant\lib and C:\Java\IntelliJ-IDEA-4.5\lib\ant\lib\org\apache\tools\ant\taskdefs
...and I pointed to the JAR in classpath (library in preferences).

The Preferences section of the Plug-in works fine. So does the UI. But this silly little FileSize class is killing me. I'm at wits end (and out of ideas about how to fix it).

I am attaching all the files:
a) the J2MESupport.jar file I downloaded from the web
b) the zip file from the Web site that has FileSize.class in it
c) the JAR file that I made from that class file
d) error messages listed below

What do you suggest?

INFO - Total time: 0 seconds

INFO - BuildProjectaction.execCommand@ process java.lang.Win32Process@dcc20cexited with code: 1

INFO - J2MESupport: Start ant build: c:\java\intellij-idea-4.5\jre\bin\java -cp .;C:/Java/J2SE/JDK/JDK1.5.0_02\jre\lib\rt.jar;C:/Java/J2SE/JDK/JDK1.5.0_02\lib\tools.jar;..\lib\ant\lib\ant.jar;..\lib\ant\lib\ant-launcher.jar;..\lib\ant\lib\FileSize.jar org.apache.tools.ant.Main -f C:\Java\Programming\PhotoWorks\build.xml dist

INFO - J2MESupport: emulator process (java.lang.Win32Process@a852b) started ...

INFO - Buildfile: C:\Java\Programming\PhotoWorks\build.xml

INFO -

INFO - BUILD FAILED

INFO - C:\Java\Programming\PhotoWorks\build.xml:26: taskdef A class needed by class FileSize cannot be found: FileSize (wrong name: org/apache/tools/ant/taskdefs/FileSize)

INFO -

INFO - Total time: 0 seconds

INFO - BuildProjectaction.execCommand@ process java.lang.Win32Process@a852bexited with code: 1

0

Hi,
i discovered how u can solve this problem:
u should give full path to FileSize class in taskdef:
1. in build.xml
2.in addition u should specify what additional jars ant-process should use. u can do it by right-mouse click in ant window on myMidlet -> properties - >]]> additional classpath and then add path to FileSize.jar

0

Please sign in to leave a comment.