Problem with DevKit

I'm working on a Simian plugin for idea 4.0 to 5.0
So i've got a module for aurora specific api, one for pallada, one for irida and one for my plugin.
Each one have his Intellij IDEA SDK.

The problem is that from time to time when i try to compile the my plugin module i've got "source -1.5 invalid" error msg !

It appears that the compiler is run with pallada's jre home and pallada's tools.jar

Looking into devkit's source i found that the internal jdk and tools path are cached... so i had to comment out

Line 122:

and change

Line 147:

to

in order to make it work.

2 comments
Comment actions Permalink

Um, you do realize that IDEA 4.5 and higher come with duplicate checking built-in, right? What's the payoff of integrating Simian?

--Dave Griffith

0
Comment actions Permalink

Yeah i know but i did it first to learn how to code a (simple) plugin for idea and second because simian has slighty different options like threshold instead of cost, ignore numbers or characters instead of ignore literals ...

0

Please sign in to leave a comment.