Using the maven plugin as dependency

I am fixing a plugin that depends on the maven plugin.
In prior versions of Intellij the plexus libraries were in the maven plugin folder, and were acccessible by the plugin I am fixing.
Now the requisite libraries have moved to subfolder of the maven folder (maven2 or maven3) in intellij 12, and the plugin can no longer see them.
Is there a way to add this classpath dependency to my plugin?

2 comments

What libraries do you need?
As workaround copy this libraries to your plugin.

0

Your suggestion was the work-around I settled on yesterday.

These are the jars that are required from the maven3 subfolder.
maven-artifacts-3.0.3.jar (version is insignicant)
plexus-utils-2.0.6.jar

0

Please sign in to leave a comment.