Can't get jboss plugin to debug jsp in IDEA 5.0 (irida) build 3273

This may just be an issue with the port of the 1.11 jboss plugin. However, it seems I cannot get the plugin to debug jsps in IDEA 5.0 (irida) build 3273. I'm able to get IDEA 4.5.4 to break at breakpoints set in the exact same jsp using the 1.11 jboss plugin, however, with the IDEA 5.0 (build 3273) and the latest 2.0-eap5 jboss plugin, although the vm seems to halt at the breakpoint, the debugger window remains frozen in the "Collecting Data..." state. I'm running all this against a jboss 3.2.5, why such an archaic version, don't ask? :)

Btw, excellent work on the jboss plugin thus far, thanks.

5 comments
Comment actions Permalink

This may just be an issue with the port of the 1.11
jboss plugin. However, it seems I cannot get the
plugin to debug jsps in IDEA 5.0 (irida) build 3273.
I'm able to get IDEA 4.5.4 to break at breakpoints
set in the exact same jsp using the 1.11 jboss
plugin, however, with the IDEA 5.0 (build 3273) and
the latest 2.0-eap5 jboss plugin, although the vm
seems to halt at the breakpoint, the debugger window
remains frozen in the "Collecting Data..." state. I'm
running all this against a jboss 3.2.5, why such an
archaic version, don't ask? :)


Seems to be some general problem, not JBoss-related: http://www.intellij.net/forums/thread.jsp?forum=22&thread=131910

0
Comment actions Permalink

You may be correct, but, for the record the jsp debugging never worked with any of the past EAP builds, as far back as I can remember. But everything works beautifully with IDEA 4.5.4? Weird eh? So you still feel this is an IDEA problem not a plugin issue? I can file something with IntelliJ, unless you have some other thoughts. Thanks again.

0
Comment actions Permalink

You may be correct, but, for the record the jsp
debugging never worked with any of the past EAP
builds, as far back as I can remember. But everything
works beautifully with IDEA 4.5.4? Weird eh? So you
still feel this is an IDEA problem not a plugin
issue? I can file something with IntelliJ, unless you
have some other thoughts. Thanks again.


The above mentioned error will be fixed in the next IDEA release. So I suppose we wait until the next build to investigate further on this issue. Until then it's too hard to separate IDEA errors from plugin errors.

0
Comment actions Permalink

In article <27710909.1112110650307.JavaMail.itn@is.intellij.net>,
ghettogirl <no_mail@jetbrains.com> wrote:

You may be correct, but, for the record the jsp debugging never worked with
any of the past EAP builds, as far back as I can remember. But everything
works beautifully with IDEA 4.5.4? Weird eh? So you still feel this is an
IDEA problem not a plugin issue? I can file something with IntelliJ, unless
you have some other thoughts. Thanks again.


JSP Debugging has worked fine for me in EAP builds for Irida, in some
ways better than Pallada (4.5.x).

R

0
Comment actions Permalink

It works for me and I use JBoss.

Norris Shelton
Sun Certified Java Programmer




ghettogirl wrote:

>You may be correct, but, for the record the jsp debugging never worked with any of the past EAP builds, as far back as I can remember. But everything works beautifully with IDEA 4.5.4? Weird eh? So you still feel this is an IDEA problem not a plugin issue? I can file something with IntelliJ, unless you have some other thoughts. Thanks again.

>

0

Please sign in to leave a comment.