Depending on Groovy plugin

Hi folks,

I need to import the Groovy PSI classes in my plugin.

I've tried using :

<depends>org.intellij.groovy</depends>

But it doesn't work : I cannot access the Groovy PSI classes (e.g. GrAnnotationArrayInitializer) which I need to inspect the code...

I'm on Ultimate 10.5.4, macos with java 6.

Any ideas ?

Thanks

Rémi

2 comments
Comment actions Permalink

Please make sure that you've added the jar of the Groovy plugin to the classpath of your IntelliJ IDEA SDK.

0
Comment actions Permalink

Works now, thanks !

0

Please sign in to leave a comment.