Changes in plugin.xml are not reflected in launched IDE application

Hello,

  I am trying to setup the delopment environment for IDEA. I cloned the the repo and try to start IDEA snapshot from the IDE and it looks like it is working. However, if I change any plugin.xml file (like description or version), then my change is not reflected. It is using some kind of cache? Shall I run it in a specific way?

1 comment
Comment actions Permalink

It looks, like the reason is that I had a wrong SDK (pointing to IntellJ Idea SDK). However, if I put to Native SDK,then I get the following stacktrace during the startup:


[  21428]  ERROR - plication.impl.ApplicationImpl - JDK: 1.6.0_26
[  21428]  ERROR - plication.impl.ApplicationImpl - VM: Java HotSpot(TM) 64-Bit Server VM
[  21428]  ERROR - plication.impl.ApplicationImpl - Vendor: Apple Inc.
[  21428]  ERROR - plication.impl.ApplicationImpl - OS: Mac OS X
[  21428]  ERROR - plication.impl.ApplicationImpl - Could not initialize class com.intellij.diagnostic.MessagePool
java.lang.NoClassDefFoundError: Could not initialize class com.intellij.diagnostic.MessagePool
 at com.intellij.diagnostic.DefaultIdeaErrorLogger.handle(DefaultIdeaErrorLogger.java:65)
 at com.intellij.diagnostic.DialogAppender$2.run(DialogAppender.java:79)
 at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:403)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:680)
 at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:131)
[  21428]  ERROR - plication.impl.ApplicationImpl - JDK: 1.6.0_26
[  21428]  ERROR - plication.impl.ApplicationImpl - VM: Java HotSpot(TM) 64-Bit Server VM
[  21428]  ERROR - plication.impl.ApplicationImpl - Vendor: Apple Inc.
[  21428]  ERROR - plication.impl.ApplicationImpl - OS: Mac OS X
[  21428]  ERROR - plication.impl.ApplicationImpl - JDK: 1.6.0_26
[  21428]  ERROR - plication.impl.ApplicationImpl - VM: Java HotSpot(TM) 64-Bit Server VM
[  21428]  ERROR - plication.impl.ApplicationImpl - Vendor: Apple Inc.
[  21428]  ERROR - plication.impl.ApplicationImpl - OS: Mac OS X
[  21428]  ERROR - plication.impl.ApplicationImpl - Could not initialize class com.intellij.diagnostic.MessagePool


How can I solve this problem?

0

Please sign in to leave a comment.